wake-up-neo.com

Android Development Tool 23.0.0 und Android L Update-Fehler in Eclipse

Ich habe mein SDK mit der neuesten Version von Android L aktualisiert und Eclipse neu gestartet, dh auf ADT V.22 ausgeführt. Wenn ich jedoch von Hep -> Check for updates nach Updates suche, wird No updates were found angezeigt. 

Ich habe manuell versucht, das ADT-Bundle von der offiziellen website herunterzuladen, und habe versucht, ADT-23.0.0.Zip von Help -> Install New Software zu installieren und die Installationsanleitung über die Site zu beschreiben, aber es gab einen Fehler 

 Cannot complete the install because of a conflicting dependency.
  Software being installed: Android Development Tools 23.0.0.1245622 (com.Android.ide.Eclipse.adt.feature.feature.group 23.0.0.1245622)
  Software currently installed: Google App Engine Tools for Android 3.5.1.v201312301719-rel-r42 (com.google.gdt.Eclipse.mobile.Android.feature.feature.group 3.5.1.v201312301719-rel-r42)
  Only one of the following can be installed at once: 
    ADT XML Overlay 22.6.3.v201404151837-1123206 (overlay.com.Android.ide.Eclipse.adt.overlay 22.6.3.v201404151837-1123206)
    ADT XML Overlay 23.0.0.1245622 (overlay.com.Android.ide.Eclipse.adt.overlay 23.0.0.1245622)
  Cannot satisfy dependency:
    From: Android Development Tools 23.0.0.1245622 (com.Android.ide.Eclipse.adt.feature.feature.group 23.0.0.1245622)
    To: overlay.com.Android.ide.Eclipse.adt.overlay [23.0.0.1245622]
  Cannot satisfy dependency:
    From: Android Development Tools 22.6.3.v201404151837-1123206 (com.Android.ide.Eclipse.adt.feature.group 22.6.3.v201404151837-1123206)
    To: overlay.com.Android.ide.Eclipse.adt.overlay [22.6.3.v201404151837-1123206]
  Cannot satisfy dependency:
    From: Google App Engine Tools for Android 3.5.1.v201312301719-rel-r42 (com.google.gdt.Eclipse.mobile.Android.feature.feature.group 3.5.1.v201312301719-rel-r42)
    To: com.Android.ide.Eclipse.adt.feature.group 22.0.0

Und es gab mir auch Fehler, wenn ich mein bestehendes Projekt kompiliere, das vor dem Update einwandfrei lief. Fehler ist:

[2014-06-27 12:03:01 - my App] The connection to adb is down, and a severe error has occured.
[2014-06-27 12:03:01 -my App] You must restart adb and Eclipse.
[2014-06-27 12:03:01 - my App] Please ensure that adb is correctly located at 'E:\Android-sdk\adt-bundle-windows-x86_64-20130522\sdk\platform-tools\adb.exe' and can be executed.

Ich war müde von verschiedenen Lösungen, die zuvor zum Abschalten des ADB-Servers und zum erneuten Starten mit dem Befehl adb kill-server bereitgestellt wurden.

Kann mir jemand erklären, wie ich mit diesem neuen SDK-Update in Eclipse meine vorhandenen Projekte erstellen und kompilieren kann.

27

Ich hatte das gleiche Problem und habe es einfach gelöst. Was ich getan habe, ist Deinstallieren Sie das Android Plugin von Eclipse (aus dem Abschnitt "Über" ..) einschließlich Trace-Ansicht ..

Starten Sie not Eclipse an dieser Stelle neu!

dann nochmal das ADT Plugin hinzugefügt ( https://dl-ssl.google.com/Android/Eclipse/ )

das problem gelöst!

Ich denke, es ist ein Fehler mit dem SDK-Manager oder dem ADT-Plugin-Update-Mechanismus.

16
Tal Kanel

Es rettet meinen Tag ...!

Wenn Sie aus irgendeinem Grund eine ADT-Vorschau installiert haben und zurücksetzen zum aktuellen Stable müssen, können Sie den Dialog nicht verwenden, um "neue" Software zu installieren, da es sich tatsächlich um eine ältere handelt. Tun Sie dies stattdessen:

  • Öffnen Sie Hilfe> Über Eclipse ... unter Windows oder Linux. Verwenden Sie auf dem Mac das Menü der -App> Info ...
  • Klicken Sie auf die Schaltfläche "Installationsdetails".
  • Wählen Sie die Registerkarte "Installationsverlauf".
  • Wählen Sie eine der vorherigen Konfigurationen.
  • Klicken Sie unten auf die Schaltfläche "Wiederherstellen".

enter image description here

6
Arsalan Mehmood

Ich bin abhängig von diesem Artikel Wie installiere ich Plugin für Eclipse von .Zip Und ich habe es sorta funktionieren lassen. braucht noch etwas von mir. Ich werde es bald aktualisieren.

Dies basiert auf der Idee, die ADT-Plugin-Zip-Datei zu öffnen und deren Inhalt von Hand zu kopieren, eine altmodische Copy-Paste-Methode. Ich konnte es immer noch nicht gut konfiguriert machen, aber die Tools funktionieren.

Vergessen Sie nicht, älteres ADT zu deinstallieren, bevor Sie dies tun.

1
superlinux

Ich hatte das gleiche Problem, schließlich musste ich ein neues ADT von http://developer.Android.com/sdk/index.html herunterladen. ist schneller als der Versuch, gegen Abhängigkeiten oder ADT-Versionen zu kämpfen.

0
ƒernando Valle