wake-up-neo.com

Android Studio-Fehler Die Bibliothek com.google.Android.gms: Play-Services-Messbasis

Wie bin ich neu bei Android Studio.

Die Bibliothek com.google.Android.gms: play-services-Measurement-base wird von verschiedenen anderen Bibliotheken unter [[15.0.0,15.0.0], [15.0.2,15.0.2]] angefordert, wird aber aufgelöst 15.0.2. Deaktivieren Sie das Plugin und überprüfen Sie die Abhängigkeitsstruktur mithilfe von ./gradlew: app: Abhängigkeiten.

2
Josip Valčić

Wie berichtet hier:

Sie müssen die Version der letzten Abhängigkeit auf 15.0.2 aktualisieren. Dies behebt das Problem, bei dem Version 3.3.0 des Google Services Gradle-Plugins meldet: Die Bibliothek com.google.Android.gms: play-services-Measurement-base wird von verschiedenen anderen Bibliotheken unter [[15.0] angefordert. 0,15.0.0], [15.0.2,15.0.2]], aber bis 15.0.2 aufgelöst ...

Aktualisieren Sie dann Ihr Google Play Services-Plugin auf 3.3.0.

classpath 'com.google.gms:google-services:3.3.0'

und aktualisieren Sie die Abhängigkeiten auf 15.0.2.

2

Beheben Sie dieses Problem mit mir - Wenn Sie sich für Firestore Database entscheiden, tun Sie Folgendes:.

buildscript {
    // ...
    dependencies {
        // ...
        classpath 'com.google.gms:google-services:4.0.1' // google-services plugin
    }
}

allprojects {
    // ...
    repositories {
        // ...
        maven {
            url "https://maven.google.com" // Google's Maven repository
        }
    }
}

nach diesem Update:

apply plugin: 'com.Android.application'

Android {
  // ...
}

dependencies {
  // ...
  implementation 'com.google.firebase:firebase-core:16.0.0'

  // Getting a "Could not find" error? Make sure you have
  // added the Google maven respository to your root build.gradle
}

// ADD THIS AT THE BOTTOM
apply plugin: 'com.google.gms.google-services'

Neu erstellen oder Sunc Now, das Problem wird behoben.

wenn Sie an der RealTime-Datenbank arbeiten, tun Sie Folgendes: -

Abhängigkeit einstellen:

implementation 'com.google.firebase:firebase-database:15.0.0'

und entferne über FireStore Dependency.

Damit lösen Sie sicher Ihr Problem ... Wenn Sie möchten, stimmen Sie für mich

1
Pradeep Sheoran
buildscript {
    // ...
    dependencies {
        // ...
        classpath 'com.google.gms:google-services:4.0.1' // google-services plugin
    }
}

Das funktioniert für mich. Durch Hinzufügen der neuesten Version, d. H. 4.0.1