wake-up-neo.com

AVD- oder SDK-Manager kann in Eclipse nicht gefunden werden

Anscheinend habe ich einige Probleme, nachdem ich meine Android-SDK-Tools und Plattform-Tools mit dem SDK-Manager aktualisiert habe. Das Problem ist, dass ich nach dem Update herausgefunden habe, dass die avd- oder sdk-Optionen im Windows-Dropdown-Menü in Eclipse weg sind! Ich kann keine Option mehr finden, um ein Android-Projekt aus Datei-> neuen Projekten zu erstellen. 

Ich habe versucht, das ADT von Eclipse und der Software-Site "https://dl-ssl.google.com/Android/Eclipse/" von "verfügbaren Software-Sites" zu entfernen, und dann das ADT von "https: // dl-ssl" neu installiert. google.com/Android/Eclipse/ "mit Hilfe -> Neue Software installieren. Die Installation war erfolgreich, aber ich habe noch keine Option für Verknüpfungen zum SDK-Manager oder zur AVD in Eclipse, und ich kann auch kein neues Android-Projekt erstellen.

Die Android-Perspektiven sind übrigens nicht verschwunden, sie sind immer noch hier. Ich kann den avd- und den sdk-Manager auch manuell von dem Verzeichnis aus öffnen, in dem ich sie installiert habe.

Kann mir bitte jemand eine Problemumgehung zeigen? Jede Hilfe wäre sehr dankbar.

87
Ishtiaque Khan

Ich habe das wie folgt gelöst:

  1. Fenster> Perspektive anpassen ... (Android und AVD Manager sind deaktiviert)

  2. Befehlsgruppenverfügbarkeit> Android und AVD Manager> prüfen 

  3. Symbolleisten-Sichtbarkeit> Android und AVD Manager> prüfen

329
joseluismms

Ich hatte ein ähnliches Problem, nachdem ich das SDK von r20 auf r21 aktualisiert hatte, aber alles, was ich vermisst hatte, war der SDK/AVD-Manager.

Ich konnte das Problem lösen, indem ich zu Window -> Customize Perspective ging, und unter Befehlsgruppen-Verfügbarkeit das Android-SDK und den AVD-Manager überprüfen (nicht sicher, warum es deaktiviert wurde, da es zuvor dort war). Ich verwende übrigens Mac, falls der Menüpunkt anders aussieht.

15
Chris Yuan

Ich fühle mich dumm, aber mein Problem war, dass ich in der Debug-Perspektive war und sie nicht in dieser Perspektive auftauchen. Zurück zur Java-Perspektive und Viola gewechselt.

4
Kenneth Hurley

Fenster -> Benutzerdefinierte Perspektive -> Befehlsgruppen - Verfügbarkeit -> Android SDK und AVD Manager prüfen 

4
user1619310

Die Chancen stehen gut, dass Sie Ihren Eclipse mit Java 1.5 ausführen. 

Latest Plugin requires that the JRE be 1.6 or higher. 

Sie müssen Eclipse verwenden, das unter JRE 1.6 ausgeführt wird

Edit: Ich hatte die gleichen Probleme. Wenn es kein JRE-Problem ist, können Sie dies debuggen. Befolgen Sie die Anweisungen unten:

  1. Fenster -> Ansicht anzeigen -> Andere -> Plugin-Entwicklung -> Plugin-Registrierung 
  2. Suchen Sie in der Plugin-Registrierungsdatenbank nach com.Android.ide.Eclipse.adt oder einem anderen Plugin, das mit Android in Verbindung steht (abhängig von Ihrer Installation möglicherweise 7-8).
  3. Wählen Sie, Rechtsklick -> Diagnose. Dies zeigt das Problem, warum das Plugin nicht geladen wurde
3
nandeesh

Leider musste ich Eclipse neu installieren. aber zuerst (unter Linux) (nicht sicher über Ordner in Windows):

Sudo rm -R /usr/share/Eclipse/
0
Michael Kern

Ich würde vorschlagen, dass Sie das mit Ihren Android SDK-Tools kompatible ADT-Plugin installieren und versuchen, alle erforderlichen Plugins zu installieren, die mit Ihrem Android SDK kompatibel sind LIKE Android SDK-Tools Rev 20.0.3 Android SDK-Tools Rev 20.0.3 Android SDK-Plattform-Tools Version 14 Android 2.3.3 (API 10) SDK-Plattform, Version 2 Beispiele für Sdk API 10 Rev 1 ADT-Plugin 20.0.3

0

Versuchen Sie, das ADT-Plugin auf Eclipse neu zu installieren. Überprüfen Sie dies: Installieren des Eclipse-Plugins