wake-up-neo.com

Com.google.Android.gms: play-services: 7.0.0 konnte nicht gefunden werden

Ich versuche, ein altes Projekt zu aktualisieren, das GMS-Bibliotheken verwendet. Bei der Gradle-Synchronisierung wird das Projekt jedoch nicht aktualisiert. Der im Titel genannte Fehler wird angezeigt.

So sieht das build.gradle aus:

project(":Android") {
    apply plugin: "Android"
    apply plugin: 'com.Android.application'

    configurations { natives }

    dependencies {
        compile project(":core")
        compile "com.badlogicgames.gdx:gdx-backend-Android:$gdxVersion"
        natives "com.badlogicgames.gdx:gdx-platform:$gdxVersion:natives-armeabi"
        natives "com.badlogicgames.gdx:gdx-platform:$gdxVersion:natives-armeabi-v7a"
        natives "com.badlogicgames.gdx:gdx-platform:$gdxVersion:natives-x86"
        compile "com.google.Android.gms:play-services:7.0.0"
    }
}

Und der Fehler ist:

Error:Could not find com.google.Android.gms:play-services:7.0.0.
Searched in the following locations:
    file:/C:/Users/Harri/.m2/repository/com/google/Android/gms/play-services/7.0.0/play-services-7.0.0.pom
    file:/C:/Users/Harri/.m2/repository/com/google/Android/gms/play-services/7.0.0/play-services-7.0.0.jar
    https://repo1.maven.org/maven2/com/google/Android/gms/play-services/7.0.0/play-services-7.0.0.pom
    https://repo1.maven.org/maven2/com/google/Android/gms/play-services/7.0.0/play-services-7.0.0.jar
    https://oss.sonatype.org/content/repositories/snapshots/com/google/Android/gms/play-services/7.0.0/play-services-7.0.0.pom
    https://oss.sonatype.org/content/repositories/snapshots/com/google/Android/gms/play-services/7.0.0/play-services-7.0.0.jar
    https://oss.sonatype.org/content/repositories/releases/com/google/Android/gms/play-services/7.0.0/play-services-7.0.0.pom
    https://oss.sonatype.org/content/repositories/releases/com/google/Android/gms/play-services/7.0.0/play-services-7.0.0.jar
Required by:
CarGame-refresh:Android:1.2

Ich habe alle erforderlichen Elemente im SDK-Manager installiert und aktualisiert:

enter image description here

Es sollte beachtet werden, dass dieses Projekt ursprünglich ein Eclipse-Projekt war, das ich gerade in Android Studio importiert habe.

BEARBEITEN: Gradle scheint nicht das richtige Verzeichnis für GMS zu finden. Es ist jedoch im SDK-Pfad installiert. Es scheint, dass das Problem hier dieser ungelösten Frage sehr ähnlich ist.

15
manabreak

Es stellt sich heraus, dass die Dokumentation möglicherweise mehr voraus ist als offiziell verfügbar.

compile 'com.google.Android.gms:play-services:6.5.87'

Scheint gut zu funktionieren, nur weil ich die folgenden Schritte gemacht habe:

Öffnen Sie die Moduleinstellungen (F12) -> Registerkarte "Abhängigkeiten" -> "+" - Zeichen -> 1) Bibliothekabhängigkeit -> com.google.Android.gms: play-services: 6.5.87

17
Mark Lapasa

Um Google Play Services Version 7.0.0 verwenden zu können, müssen Sie die Google Play Services und das Google Repository auf Rev. 23 & 16 bzw. im Abschnitt Extras des Android SDK Manager aktualisieren.

Um den Android SDK Manager in Android Studio zu öffnen, gehen Sie zu Extras -> Android -> SDK Manager.

Bearbeiten : Außerdem müssen Sie Ihre SDK-Tools auf Rev. 24.1.2, SDK-Plattform-Tools auf Rev. 22 und optional die SDK-Build-Tools auf Rev. 22.0.1 aus dem Abschnitt Tools des SDK-Managers aktualisieren. 

16
Hassaan

Aktualisieren Sie zunächst dieAndroid SDK-Tools,Android SDK-Build-Tools, Android SDK-Plattform-Tools.

Aktualisieren Sie dannGoogle Play-Dienste und Google Repositoryaus dem SDK-Manager . Sie befinden sich im Abschnitt "Extras" des SDK-Managers.

Das hat bei mir funktioniert.

2
Swapnil Kale

Sie sollten 6.5.87 anstelle von 7.0.0 verwenden.

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    compile 'com.google.Android.gms:play-services-maps:6.5.87'
    compile 'com.google.Android.gms:play-services-drive:6.5.87'
}
1
Ryan Le

Sie müssen diese Zeile nur zu Ihren Abhängigkeiten hinzufügen und Ihr Projekt neu erstellen:.

0
issam