wake-up-neo.com

Das ADT-Plugin in Eclipse kann nicht auf Version 23.0.0 oder höher aktualisiert werden

Ich bin Anfänger in Android Programmierung. Mein Problem ist, dass ich ADT nicht aktualisieren kann. Das Problem begann, als ich nach langer Zeit in Android aktualisiert habe SDK Manager Android SDK Tools. Dann habe ich versucht, ein Projekt in den Arbeitsbereich zu importieren. Das konnte ich jedoch nicht importieren, da jedes Mal, wenn ich auf die Schaltfläche "Fertig stellen" klickte, nichts passierte. Dann habe ich schloss Eclipse und öffnete es erneut und zeigte mir den folgenden Fehler:

enter image description here

Ich habe auf Nach Updates suchen geklickt, aber nichts gefunden. Im Internet habe ich eine [~ # ~] url [~ # ~] gefunden, also habe ich auf Hilfe -> Neue Software installieren ...--> Hinzufügen -> geklickt und eingefügt diese URL. Als ich auf Weiter geklickt habe, wurde mir die Liste der Elemente angezeigt, die ich installieren wollte, sowie ein Fehler:

Cannot complete the install because of a conflicting dependency.
 Software being installed: Tracer for OpenGL ES 23.0.0.1245622 (com.Android.ide.Eclipse.gldebugger.feature.feature.group 23.0.0.1245622)
 Software currently installed: Tracer for OpenGL ES 21.0.0.v201210310015-519525 (com.Android.ide.Eclipse.gldebugger.feature.group 21.0.0.v201210310015-519525)
Only one of the following can be installed at once: 
Tracer for OpenGL ES 23.0.0.1245622 (com.Android.ide.Eclipse.gldebugger 23.0.0.1245622)
Tracer for OpenGL ES 21.0.0.v201210310015-519525 (com.Android.ide.Eclipse.gldebugger 21.0.0.v201210310015-519525)
Cannot satisfy dependency:
From: Tracer for OpenGL ES 23.0.0.1245622 (com.Android.ide.Eclipse.gldebugger.feature.feature.group 23.0.0.1245622)
To: com.Android.ide.Eclipse.gldebugger [23.0.0.1245622]
Cannot satisfy dependency:
From: Tracer for OpenGL ES 21.0.0.v201210310015-519525 (com.Android.ide.Eclipse.gldebugger.feature.group 21.0.0.v201210310015-519525)
To: com.Android.ide.Eclipse.gldebugger [21.0.0.v201210310015-519525]

Ich habe auch irgendwo gelesen, dass ich versuchen sollte, den Plugins-Ordner durch den aktualisierten Plugins-Ordner zu ersetzen, also habe ich versucht, den "Plugins" -Ordner im Eclipse-Ordner in "Pluginsx" umzubenennen und den neuen Ordner, den ich von heruntergeladen habe, eingefügt. -site . Danach konnte ich die Sonnenfinsternis nicht öffnen.

Diese site handelt auch von demselben Problem wie ich, und es gibt eine Antwort, die als Lösung der Frage akzeptiert wird. Also habe ich auch versucht download , und diese 3 Dinge in Ordner kopiert, die im Kommentar unten erwähnt wurden, aber ich habe immer noch das gleiche Problem, nichts geändert.

Jetzt habe ich keine Ahnung, wie ich dieses Problem beheben kann. Kann mir bitte jemand helfen?

Danke im Voraus.

34
adamhala007

Hilfe -> Neue Software installieren -> Was ist bereits installiert?

Wählen Sie dann "Android DDMS, Andoid-Entwicklungstools, Android-Hierarchie-Viewer, Android native Entwicklungstools, Android Traceview, Tracer für OpenGL ES") "und klicken Sie auf" Deinstallieren ".

Versuchen Sie nach all diesen Schritten, einen Link hinzuzufügen ( https://dl-ssl.google.com/Android/Eclipse/ ). Der Name lautet ADT Plugin. Über diesen Link erhalten Sie das neueste ADT-Plugin. Auf diese Weise installieren Sie das ADT neu.

35
serifsadi

Keine dieser "Aktualisierungen" allein hat bei mir funktioniert.

Die Lösung, die ich verwendet habe, ist das ADT zu deinstallieren (von Deinstallieren Android ADT)

Help > About Eclipse > Installation Details

Wähle alle Android Module mit dem Präfix com.Android.ide ...)

und löschen Sie sie (Deinstallieren ...) und fügen Sie die Bibliotheken erneut aus der hinzu

help > Install new software

Wie oben aufgeführt ....

9
Stuart Siegler

Die einzige Lösung, die mir geholfen hat, war das Herunterladen des aktuellen Eclipse ADT-Bundles von der Android site

Nach dem Download habe ich mein aktuelles SDK in einen Ordner wie .../development/sdk kopiert. Dann habe ich die mit diesem neuen Bundle gelieferte SDK gelöscht.

Ich habe ADT Bundle in .../development/adt-bundle -... eingefügt. Nach dem Start müssen Sie den neuen SDK-Speicherort in Window > Preferences > Android, also in SDK-Speicherort legen Sie den neuen SDK-Pfad. In meinem Fall: .../development/sdk .

Natürlich können Sie den Ordner "sdk" in den neuen Ordner "ADT Bundle" einfügen, aber ich mache das auch so, weil ich "Android Studio") verwende und die beiden IDEs auf dasselbe SDK verweise.

Nachdem dies abgeschlossen ist und sichergestellt ist, dass alles funktioniert, habe ich den alten ADT-Bundle-Ordner gelöscht.

1
androidevil

Die Installation von ADT ist insbesondere beim Aktualisieren ein großes Problem. Manchmal ist es auch nur mühsam, ADT über den direkten Link zu installieren. Oft wird Eclipse angehalten, während "Anforderungen und Abhängigkeiten berechnen" angezeigt wird.

Ich fand es manchmal einfacher, zuerst alle 7 Komponenten zu deinstallieren:

-Android DDMS
- Andoid Devlopment Tools
- Android Hierarcy Viewer
- Native Android-Entwicklungstools
- Android Traceview
- Tracer für OpenGL ES
- Google App Engine-Tools für Android (falls installiert)

Laden Sie dann das neueste Zip/Archiv herunter.

Installieren Sie das Archiv über Hilfe-> Neue Software installieren-> Hinzufügen-> Archiv
Wählen Sie die heruntergeladene Zip aus, geben Sie einen Namen dafür ein und folgen Sie dem Standardinstallationsprozess.

0
ZakiMak

Ich hatte das gleiche Problem und die folgende Lösung funktionierte für mich.

Ich hatte die SDK-Plattform von M Preview installiert, während mein ADT die Version 22 hatte. Also habe ich gerade die SDK-Plattform von M Preview deinstalliert und die SDK-Plattform der API-Stufe 22 aus dem SDK-Manager installiert.

Das hat bei mir funktioniert.

0
user3843681

diese Lösung funktioniert. !!!!!!!

Öffnen Sie Eclipse> Hilfe> Informationen zu Eclipse> Installation

deinstallieren Sie die Komponente, die in der heruntergeladenen ZIP-Datei enthalten ist. Download wie unten.

(danke an mr.zakimark

Ich fand es manchmal einfacher, zuerst alle 7 Komponenten zu deinstallieren:

-Android DDMS -Android-Entwicklungstools -Android Hierarcy Viewer -Android-native Entwicklungstools -Android Traceview -Tracer für OpenGL ES -Google App Engine-Tools für Android (falls installiert)

Laden Sie dann das neueste Zip/Archiv herunter.

Installieren Sie das Archiv über Hilfe-> Neue Software installieren-> Hinzufügen-> Archiv. Wählen Sie die heruntergeladene Zip-Datei aus, geben Sie einen Namen für sie ein und folgen Sie dem Standardinstallationsprozess.

0
caseres

Ich konnte die alten ADT-Plugins nicht von der Seite "Hilfe-> Installationsdetails" deinstallieren, da die Schaltfläche "Deinstallieren ..." deaktiviert war, als ich eines der Module auswählte.

Da das ADT-Bundle nicht mehr zum Herunterladen verfügbar ist, kam eine Neuinstallation nicht in Frage.

Für mich hat es funktioniert, die grundlegende Eclipse-Umgebung mithilfe des Eclipse-Installationsprogramms von hier zu installieren. Im Installationsprogramm habe ich "Erweiterter Modus ..." aus dem Hamburger-Menü ausgewählt und dann nur die zu installierende "Eclipse-Plattform" ausgewählt, d. H. Nur die Kerntools. Ich denke, dass dies nur mit dem Installer möglich ist.

Nach der Installation von Eclipse habe ich alle ADT-Plugins mithilfe von "Hilfe-> Neue Software installieren" und mithilfe von link https://dl-ssl.google.com/Android/Eclipse/ installiert.

YMMV, aber das hat bei mir funktioniert.

0
zelanix