wake-up-neo.com

Die Bibliothek com.google.Android.gms: play-services-basement wird von verschiedenen anderen Bibliotheken unter [[15.0.1,15.0.1]] angefordert, löst sich jedoch in 11.8.0 auf

Ich möchte eine Benachrichtigung mit Firebase auf meiner App hinzufügen Ich habe ein Video auf YouTube verfolgt ( https://www.youtube.com/watch?v=xx7hemn3FY4 ) Ich habe jedoch einen Fehler Wenn ich dasselbe in meinem Flatterprojekt mache: Die Bibliothek com.google.Android.gms: play-services-basement wird von verschiedenen anderen Bibliotheken in [[15.0.1,15.0.1]] angefordert, löst sich jedoch in 11.8 auf .0. Deaktivieren Sie das Plugin und überprüfen Sie die Abhängigkeitsstruktur mithilfe von ./gradlew: app: Abhängigkeiten.

Ich habe verschiedene Dinge ausprobiert, wie Sie im Kommentar sehen können.

Projektabschluss:

 buildscript {
    repositories {
        google()
        jcenter()
    }

dependencies {
    classpath 'com.Android.tools.build:gradle:3.0.1'

    classpath 'com.google.gms:google-services:4.0.1'
    //classpath 'com.google.gms:google-services:4.0.0'

}
}

allprojects {
    repositories {
        google()
        jcenter()
        /*
        maven {
            url "https://maven.google.com" // Google's Maven repository
        }
        */
    }
}

rootProject.buildDir = '../build'
subprojects {
    project.buildDir = "${rootProject.buildDir}/${project.name}"
}
subprojects {
    project.evaluationDependsOn(':app')
}

task clean(type: Delete) {
    delete rootProject.buildDir
}

subprojects {
    project.configurations.all {
        resolutionStrategy.eachDependency { details ->
            if (details.requested.group == 'com.Android.support'
                    && !details.requested.name.contains('multidex') ) {
                details.useVersion "27.1.0"
            }

        }
    }
}

App Gradle:

def localProperties = new Properties()
def localPropertiesFile = rootProject.file('local.properties')
if (localPropertiesFile.exists()) {
    localPropertiesFile.withReader('UTF-8') { reader ->
        localProperties.load(reader)
    }
}

def flutterRoot = localProperties.getProperty('flutter.sdk')
if (flutterRoot == null) {
    throw new GradleException("Flutter SDK not found. Define location with flutter.sdk in the local.properties file.")
}

apply plugin: 'com.Android.application'
apply from: "$flutterRoot/packages/flutter_tools/gradle/flutter.gradle"

Android {
    compileSdkVersion 27

    lintOptions {
        disable 'InvalidPackage'
    }

    defaultConfig {
        // TODO: Specify your own unique Application ID (https://developer.Android.com/studio/build/application-id.html).
        applicationId "com.example.weatherapp"
        minSdkVersion 16
        targetSdkVersion 27
        versionCode 1
        versionName "1.0"
        testInstrumentationRunner "Android.support.test.runner.AndroidJUnitRunner"
    }

    buildTypes {
        release {
            // TODO: Add your own signing config for the release build.
            // Signing with the debug keys for now, so `flutter run --release` works.
            signingConfig signingConfigs.debug
        }
    }
}

flutter {
    source '../..'
}

dependencies {
    testImplementation 'junit:junit:4.12'
    androidTestImplementation 'com.Android.support.test:runner:1.0.1'
    androidTestImplementation 'com.Android.support.test.espresso:espresso-core:3.0.1'
    //Implementation 'com.google.Android.gms:play-services-basement:15.0.1'
    //Implementation 'com.google.firebase:firebase-core:15.0.0'
}

apply plugin: 'com.google.gms.google-services'

Aber keine dieser Änderungen funktioniert. Hast du eine andere Idee?

5
Fabien

Ich war mit dem ähnlichen Problem konfrontiert, wo in der Fehlermeldung darauf hingewiesen wird 

Die Bibliothek com.google.Android.gms: play-services-basement wird von verschiedenen anderen Bibliotheken unter [[15.0.1,15.0.1]] angefordert, aber wird in 11.8.0 aufgelöst. Deaktivieren Sie das Plugin und überprüfen Sie die Abhängigkeitsstruktur mithilfe von ./gradlew: app: Abhängigkeiten.

Gelöst aufgelöst zu 11.8.0

dependencies {
    testImplementation 'junit:junit:4.12'
    androidTestImplementation 'com.Android.support.test:runner:1.0.1'
    androidTestImplementation 'com.Android.support.test.espresso:espresso-core:3.0.1'
    //Implementation 'com.google.Android.gms:play-services-basement:15.0.1'
    //Implementation 'com.google.firebase:firebase-core:15.0.0'

   implementation 'com.google.firebase:firebase-core:11.8.0'.  // <<--- Add this
}

Ich löste meine Frage durch Hinzufügen der Zeile 

implementation 'com.google.firebase:firebase-core:11.8.0'.  // <<--- Add this

Wenn das Problem dadurch nicht behoben wird, fügen Sie diese Zeile hinzu.

com.google.gms.googleservices.GoogleServicesPlugin.config.disableVersionCheck = true

am Ende derselben Datei wie unten;

...

dependencies {
  ....
}

....

com.google.gms.googleservices.GoogleServicesPlugin.config.disableVersionCheck = true

Lassen Sie mich wissen, ob es unser Problem gelöst hat.

Vielen Dank!

4
Rajan Maharjan

Dieser Konflikt tritt auf, weil die Verwendung älterer Bibliotheken verwendet wurde. Die neueste Version ist . In meinem Fall habe ich die Version 16.0.0 von Firebase verwendet.

 implementation 'com.google.firebase:firebase-core:16.0.0'

lieber als das

 implementation 'com.google.firebase:firebase-core:16.0.4'
0
Muhammed Fasil