wake-up-neo.com

Emulator: Emulator: WARNUNG: UpdateCheck: Fehler: Fehler

Ich konnte meine unten gezeigte AVD erfolgreich ausführen avd

Nach einigen API-Aktualisierungen und einem Update von Android Studio auf 3.0 kann ich die AVD jedoch nicht erneut erfolgreich ausführen. Erhalten Sie den Fehler weiter unten: avd error

Mein AVD ist auch super langsam und ich habe einen Windows-PC mit 8 GB RAM.

Unten sind die Details meines AVD.

Name: Pixel_API_25

CPU/ABI: Google APIs Intel Atom (x86)

Path: C:\Users\Blah\.Android\avd\Pixel_API_25.avd

Target: google_apis [Google APIs] (API level 25)

Skin: pixel

SD Card: 100 MiB

hw.dPad: no

hw.lcd.height: 1920

runtime.network.speed: full

hw.accelerometer: yes

hw.device.name: pixel

vm.heapSize: 256

skin.dynamic: yes

hw.device.manufacturer: Google

hw.lcd.width: 1080

hw.gps: yes

hw.initialOrientation: Portrait

image.androidVersion.api: 25

hw.audioInput: yes

image.sysdir.1: system-images\Android-25\google_apis\x86\

tag.id: google_apis

showDeviceFrame: yes

hw.camera.back: emulated

hw.mainKeys: no

AvdId: Pixel_API_25

hw.camera.front: emulated

hw.lcd.density: 480

avd.ini.displayname: Pixel API 25

hw.gpu.mode: auto

hw.device.hash2: MD5:524882cfa9f421413193056700a29392

hw.ramSize: 1024

hw.trackBall: no

PlayStore.enabled: false

fastboot.forceColdBoot: no

hw.battery: yes

hw.cpu.ncore: 2

hw.sdCard: no

tag.display: Google APIs

runtime.network.latency: none

hw.keyboard: yes

hw.sensors.proximity: yes

disk.dataPartition.size: 800M

hw.sensors.orientation: yes

avd.ini.encoding: UTF-8

hw.gpu.enabled: yes

Bitte helfen.

6
tobbyioa

Sie sollten denHAXMdeinstallieren und neu installieren. Stellen Sie sicher, dass ihm mindestens 2 GB RAM zugewiesen werden. und wenn Sie Ihr emuliertes Gerät erstellen, geben Sie weniger, als Sie demHAXMgaben. Ich würde sagen, 1 GB würde die Dinge beschleunigen. aber ich würde vorschlagen, dass mehr RAM 8 GB niedrig ist. Mein System verwendet 10 GB mit Google Chrome, Android Studio und geöffnetem Emulator. Wenn Sie zu einer neuen Version wechseln, gehen Sie auch zu Datei> Caches ungültig machen/Neustart  

3
Mihai

Ich hatte das gleiche Problem mit Android Studio 3.0.1, versuchte oben zu folgen, funktionierte aber nicht.

Dieses Problem wurde durch das seltsame Ändern des Ziels von "Open Select Deployment Target Dialog" in "Emulator" in "Run/Debug Configuration" behoben.

Test-App wurde installiert. Nach erfolgreicher Installation habe ich das Target immer noch zurückgesetzt.

1
SMa

Möglicherweise ist Ihre h/w-Beschleunigung deaktiviert. Sie sollten versuchen, die h/w-Beschleunigung über das BIOS zu aktivieren. Dies kann bei langsamer Geschwindigkeit helfen.

0
shubham jadhav

Stellen Sie sicher, dass Sie über eine stabile Internetverbindung mit Ihren bevorzugten Proxy-Einstellungen verfügen. Meine Unternehmensproxyeinstellungen haben diesen Fehler verursacht. 

0
Onat Korucu

Möglicherweise reicht auch das Löschen von Daten für Ihr virtuelles Gerät (Löschen von Daten aus dem Dropdown-Menü Aktionen).

0
zmeeagain

Ich habe alles versucht, aber nicht funktioniert. Am Ende müssen Sie den Emulator löschen und einen neuen wie folgt erstellen:

in diesem Pfad C:/user/username/.Android/avd den Ordner löschen und IDE neu starten. Dann einen neuen Emulator erstellen.

0
Mustafa Shahoud