wake-up-neo.com

fehler beim Bündeln: Fehler: Das Plugin hat eine ungültige Eigenschaft von "default" angegeben.

Ich versuche, eine reaktive native App auf meinem AVD mit folgendem Befehl auszuführen:

react-native run-Android

aber folgenden Fehler bekommen:

 bundling failed: Error: Plugin 0 specified in "C:\\Users\\ASUS\\test\\node_modules\\babel-preset-react-native\\index.js" provided an invalid property of "default" (While processing preset: "C:\\Users\\ASUS\\test\\node_modules\\babel-preset-react-native\\index.js")
    at Plugin.init (C:\Users\ASUS\test\node_modules\babel-core\lib\transformation\plugin.js:131:13)
    at Function.normalisePlugin (C:\Users\ASUS\test\node_modules\babel-core\lib\transformation\file\options\option-manager.js:152:12)
    at C:\Users\ASUS\test\node_modules\babel-core\lib\transformation\file\options\option-manager.js:184:30
    at Array.map (<anonymous>)
    at Function.normalisePlugins (C:\Users\ASUS\test\node_modules\babel-core\lib\transformation\file\options\option-manager.js:158:20)
    at OptionManager.mergeOptions (C:\Users\ASUS\test\node_modules\babel-core\lib\transformation\file\options\option-manager.js:234:36)
    at C:\Users\ASUS\test\node_modules\babel-core\lib\transformation\file\options\option-manager.js:265:14
    at C:\Users\ASUS\test\node_modules\babel-core\lib\transformation\file\options\option-manager.js:323:22
    at Array.map (<anonymous>)

.babelrc:

{
  "presets": [
    "react-native"
    "@babel/preset-flow"
  ]
}

package.json:

{
  "name": "test",
  "version": "0.0.1",
  "private": true,
  "scripts": {
    "start": "node node_modules/react-native/local-cli/cli.js start",
    "test": "jest"
  },
  "dependencies": {
    "react": "16.4.1",
    "react-native": "^0.55.4"
  },
  "devDependencies": {
    "babel-jest": "23.4.0",
    "babel-preset-react-native": "5.0.2",
    "jest": "23.4.1",
    "react-test-renderer": "16.4.1"
  },
  "jest": {
    "preset": "react-native"
  }
}

Ich verwende Windows, node.js v 8.11.3 & react native v 0.55.4

Ich habe schon alles probiert, was im Internet empfohlen wird (speziell github), aber immer noch kein Glück. Wirklich zu schätzen, wenn jemand helfen kann.

9
Zeinab Rostami

Dies ist ein Fehler in babel-preset-react-native

Stellen Sie die Version ein:

yarn remove babel-preset-react-native
yarn add [email protected]
12

Es gibt einige inkompatible Versionierungsprobleme in React native. Versuchen Sie dies, es wird funktionieren

1.Ändern Sie folgende Versionen in package.json

In Abhängigkeiten: -

  "react": "16.3.1"
  "react-native": "0.55.4"

In devDependencies: -

  "babel-preset-react-native": "2.1.0"

2. Löschen Sie node_modules und führen Sie npm aus. --Save  

  1. Starten Sie dann die Anwendung von React-native run-Android

Es wird gut laufen ...

2
Chirag Sharma

Ich hatte dieses Problem und musste die Version von babel-preset-react-native herunterstufen. 

Wenn Sie Garn verwenden

yarn remove babel-preset-react-native
yarn add [email protected]

oder npm-Befehle verwenden

npm uninstall babel-preset-react-native
npm install [email protected]
1
Khemraj

Sollte der Scherz der neuesten Version verwendet werden, kann dies funktionieren "babel-jest": "23.3.0", "babel-preset-react-native": "5.0.2", "jest": "23.3.0",

1
colorfulberry

Nun, es kann zu spät sein, aber ich werde anderen helfen, da package.json bis zum 20. August 2018 arbeitet

Unter package.json die meisten Abhängigkeiten wie Axios, Redux, Native Base, Reaktiver-Router-Flux .. etc in reaktiven Projekten, so dass ich die unten genannte Kompatibilität miteinander erwähnte. Prost.

{
  "name": "Example",
  "version": "0.0.1",
  "private": true,
  "scripts": {
    "start": "node node_modules/react-native/local-cli/cli.js start",
    "test": "jest"
  },
  "resolutions": {
    "*/@babel/cli": "7.0.0-beta.54",
    "*/@babel/core": "7.0.0-beta.54",
    "*/@babel/code-frame": "7.0.0-beta.54"
  },
  "dependencies": {
    "axios": "^0.18.0",
    "eslint": "^5.2.0",
    "native-base": "2.6.1",
    "prop-types": "^15.6.2",
    "react": "16.3.1",
    "react-native": "0.55.4",
    "react-native-router-flux": "^4.0.1",
    "react-native-timeline-listview": "^0.2.3",
    "react-navigation": "^2.11.2",
    "react-redux": "^5.0.7",
    "redux": "^4.0.0",
    "redux-logger": "^3.0.6",
    "redux-thunk": "^2.3.0"
  },
  "devDependencies": {
    "babel-jest": "23.4.2",
    "babel-preset-react-native": "4.0.0",
    "jest": "23.5.0",
    "react-test-renderer": "16.4.1"
  },
  "jest": {
    "preset": "react-native"
  }

}
0
Abhiode