wake-up-neo.com

Wie kann ich das `PlaceAutocompleteFragment` beheben lassen?

Wie kann ich das PlaceAutocompleteFragment auflösen lassen?

Hallo Leute, ich versuche die neue PlaceAutocompleteFragment zu verwenden. Ich versuche folgenden Code zu verwenden:

<fragment
  Android:id="@+id/place_autocomplete_fragment"
  Android:layout_width="match_parent"
  Android:layout_height="wrap_content"
  Android:name="com.google.Android.gms.location.places.ui.PlaceAutocompleteFragment"
  />

Dieses Codebeispiel ist nur eine Kopie. Es ist von dieser site . Allerdings ist PlaceAutocompleteFragment in meinem Fall nicht gelöst. Wie kann ich dieses Problem beheben? Ich denke, die Lösung muss sehr einfach sein.) für einige Zeit.

20
Gilian

Für die Verwendung von PlaceAutocompleteFragment müssen wir eine Lib in Gradle .__ hinzufügen. Fügen Sie dies hinzu 

implementierung "com.google.Android.gms: play-services-places: 16.0.0"

ich habe dies in meinem Android-Studio überprüft. Bitte teilen Sie mir mit, ob Ihr Problem gelöst ist.

Überprüfen Sie die Version (16.0.0 zum Zeitpunkt des Schreibens) von play-services hier .
(Aus dem Kommentar unten)

63
Mahesh Giri

Ändern Sie einfach Ihre Compile-Bibliothek in Gradle von "Standorten" in "Orte".

zum Beispiel

veränderung 

com.google.Android.gms: play-services-location: "Ihre Version" 'kompilieren

zu

comp.google.Android.gms: play-services-places: "Ihre Version" 'kompilieren

3

Sie müssen eine Bibliothek in Gradle hinzufügen

compile 'com.google.Android.gms:play-services-location:10.0.1'

verwenden Sie die gleiche Version "10.0.1" oder das, was Sie aktuell in Ihrem Dienst in beiden Diensten haben. 

Beispiel:-

compile 'com.google.Android.gms:play-services-maps:10.0.1'
compile 'com.google.Android.gms:play-services-location:10.0.1'
1
Abhishek Kumar

benutzt implementation 'com.google.Android.gms:play-services-places:16.0.0' hatte aber immer noch Probleme mit 'PlaceAutocompleteFragment'

Muss hinzufügen

implementation 'com.google.Android.libraries.places:places:1.1.0'

0
Shashank Bhong