wake-up-neo.com

FEHLER im Angular Compiler erfordert TypeScript> = 3.1.1 und <3.2.0, aber stattdessen wurde 3.2.1 gefunden

Ich erhalte diesen Fehler

FEHLER im Angular Compiler erfordert TypeScript> = 3.1.1 und <3.2.0, aber stattdessen wurde 3.2.1 gefunden.

Scheint wie TypeScript aktualisiert, aber der Angular Compiler mag das nicht.

Wie behebe ich das?

122
Matt

Um dies zu beheben, installieren Sie die spezifische TypeScript-Version 3.1.6

npm i [email protected] --save-dev --save-exact
160
Matt

In meinem Fall funktionierte der folgende Befehl für Windows. Es wird die neueste erforderliche Version zwischen 3.1.1 und 3.2.0 installiert. Verwenden Sie je nach Betriebssystem doppelte oder einfache Anführungszeichen

npm install [email protected]">=3.1.1 <3.2.0" 
123
Sushil Jadhav

Installieren Sie zuerst Ihre Zielversion

npm i [email protected] --save-dev --save-exact

Dann vor dem Kompilieren machen

   npm i
23
npm install [email protected]">=3.1.1 <3.3.0" --save-dev --save-exact
rm -rf node_modules
npm install
12
Pala

Es wurde ein ähnlicher Fehler aus dem Fehlerprotokoll von CircleCi gemeldet.

"FEHLER im Angular-Compiler erfordert TypeScript> = 3.1.1 und <3.3.0, aber stattdessen wurde 3.3.3333 gefunden."

Nur damit Sie wissen, dass dies keinen Einfluss auf die Angular -Anwendung hatte, aber der CircleCi-Fehler wurde ärgerlich. Ich laufe Angular 7.1

Ich habe ausgeführt: $ npm i [email protected] --save-dev --save-exact, um die Datei package-lock.json zu aktualisieren.

Dann lief ich: $ npm i

Danach habe ich ausgeführt: $ npm audit fix

"Diese CircleCi-Fehlermeldung" wurde entfernt. So funktioniert es

4
Marvin Dawson