wake-up-neo.com

Es wurde keine geeignete Version für die Winkelverlegung gefunden

Ich habe meine Angular-App so eingerichtet, dass sie nach Heroku bower install ausgeführt wird. Ich erhalte jedoch Fehler aufgrund von Versionsproblemen.

Wenn ich bower install lokal starte, bekomme ich Folgendes angezeigt:

Unable to find a suitable version for angular, please choose one:                                                                           
    1) angular#1.2.16 which resolved to 1.2.16 and is required by angular-resource#1.2.16                                                   
    2) angular#1.2.23 which resolved to 1.2.23 and is required by angular-cookies#1.2.23                                                    
    3) angular#>= 1.0.8 which resolved to 1.2.25 and is required by angular-ui-router#0.2.10                                                
    4) angular#^1 which resolved to 1.2.25 and is required by angular-ui-codemirror#0.1.6                                                   
    5) angular#~1.2.2 which resolved to 1.2.25 and is required by splitter#f5c2195050                                                       
    6) angular#>=1.0.6 which resolved to 1.2.25 and is required by angular-elastic#2.4.0                                                    
    7) angular#~1.2 which resolved to 1.2.25 and is required by angular-nanoscroller#0.2.1                                                  
    8) angular#~1.2.9 which resolved to 1.2.25 and is required by angular-sockjs#0.0.1Prefix the choice with ! to persist it to bower.json  

? Answer::  

Was soll ich damit tun? Ich brauche wegen der Debounce-Funktion Version 1.3 von Angular

Mein bower.json sieht so aus:

{
  "name": "myapp",
  "version": "0.0.1",
  "dependencies": {
    "json3": "~3.3.1",
    "es5-shim": "~3.1.0",
    "angular-resource": "1.2.16",
    "angular-sanitize": "1.2.16",
    "angular-animate": "1.2.16",
    "angular-ui-router": "~0.2.10",
    "jquery": "~2.1.1",
    "angular-ui-codemirror": "~0.1.6",
    "splitter": "*",
    "angular-cookies": "~1.2.23",
    "angular-elastic": "~2.4.0",
    "angular-local-storage": "~0.0.7",
    "chance": "~0.5.6",
    "nanoscroller": "~0.8.4",
    "angular-nanoscroller": "~0.2.1",
    "angular-sockjs": "~0.0.1"
  }
}
48
tommyd456

Aktualisieren Sie Ihre aktuellen Winkelabhängigkeiten auf 1.3.x und fügen Sie eine Auflösung für den Winkel hinzu, um die Eingabeaufforderung zu unterdrücken:

{
  "name": "myapp",
  "version": "0.0.1",
  "dependencies": {
    "angular": "~1.3.x",
    "angular-animate": "~1.3.x",
    "angular-cookies": "~1.3.x",
    "angular-resource": "~1.3.x",
    "angular-sanitize": "~1.3.x",
    "angular-ui-router": "~0.2.10",
    "angular-ui-codemirror": "~0.1.6",
    "angular-elastic": "~2.4.0",
    "angular-local-storage": "~0.0.7",
    "angular-nanoscroller": "~0.2.1",
    "angular-sockjs": ">=0.0.1",
    "json3": "~3.3.1",
    "es5-shim": "~3.1.0",
    "jquery": "~2.1.1",
    "splitter": "*",
    "chance": "~0.5.6",
    "nanoscroller": "~0.8.4"
  },
  "resolutions": {
    "angular": "~1.3.x"
  }
}
74
naeramarth7

Eine sehr gute Erklärung und Lösung des Problems finden Sie hier:

Bower-Auflösungen

Kopieren Sie einfach das Einfügen einiger Zeilen als Referenz:

Wenn Sie über Bower Abhängigkeiten für Ihre App festlegen, hängen einige Pakete möglicherweise von verschiedenen Versionen derselben Bibliothek ab. Sie müssen die Version der Bibliotheken ermitteln, die Ihre App tatsächlich möchte. Mit anderen Worten, Sie brechen die Krawatte. Aber Sie wollen es nicht jedes Mal kaputt machen, also speichern Sie Ihre Wahl.

Wenn Sie die Bower-Installation ausführen, ist der Auflösungsprozess interaktiv. Wenn Bower erkennt, dass es zwei Pakete gibt, die in verschiedenen Versionen von einem Paket abhängen, werden alle diese Versionen aufgelistet und folgende Frage gestellt:

 enter image description here

Die nächste Zeile in der Aufforderung ist sehr praktisch. Es liest:

 enter image description here

Genial! Wenn ich also! 2 eingebe, wird meine Auswahl in bower.json gespeichert. Insbesondere wird ein Auflösungseintrag hinzugefügt:

 enter image description here

Bei der nächsten Bower-Installation wird jetzt keine interaktive Frage nach der gewünschten Version gestellt, da ich bereits entschieden habe, dass der Ember für meine App Version 1.5.1 ist.

17
A.I

Sie sollten Bower aktualisieren (es funktioniert für mich):

bower update
9
Luillyfe

Löschen Sie das Verzeichnis/bower_components und führen Sie bower install erneut aus.

Ein Hack aber funktioniert trotzdem .. !!

3

Sie können den Installationsbefehl ausführen. Wenn Sie zur Auswahl der Version aufgefordert werden, verwenden Sie das Ausrufezeichen (!) Als Präfix für die Option. Zum Beispiel! 3 für die dritte Option . Dies wird dann zur bower.json-Datei Ihrer Anwendung hinzugefügt und der Konflikt wird gelöst.

Hoffe das hilft.

1
Arif Banduwale

Versuchen Sie es zuerst:
npm install -g bower

Wenn die oben genannte Lösung nicht funktioniert, versuchen Sie Folgendes:

bower Update
0
user3365771