wake-up-neo.com

Kann das NuGet-Paket nicht installieren

Ich versuche, das Unity-Paket zu meiner Lösung hinzuzufügen, erhalte aber weiterhin die aufgeführte Nachricht:

Versuch, die Abhängigkeit 'Unity (≥ 3.5.1404.0)' aufzulösen.

'Unity' hat bereits eine Abhängigkeit für 'CommonServiceLocator' definiert.

Irgendeine Idee, wie man das beheben kann?

24
Jaster

Dieses Problem tritt bei älteren Versionen von Nuget auf. Update nuget PM, 2.8.50313.46 ist aktuelle Version. Suchen Sie die neueste Version für VS 2012

31
Rao Ehsan

Sie verwenden die höhere Version .Net Framework ..__ und fügen der niedrigeren Version von Unity hinzu.

ihr Application Framework wird über 4.0 oder 4.0 liegen, und Sie fügen Unity-Framearbeit hinzu, die den .net-Frame 3.5 enthält.

0
Saineshwar