wake-up-neo.com

Die Installation des subversiven SVN-Connectors schlägt in Eclipse Oxygen fehl

Die Installation der subversiven SVN-Connectors schlägt derzeit mit Eclipse Oxygen fehl.

Eclipse.log

!ENTRY org.Eclipse.team.svn.core.svnnature 4 0 2017-07-03 10:55:36.977
!MESSAGE SVN: 'SVN Decorator' operation finished with error
!SUBENTRY 1 org.Eclipse.team.svn.core.svnnature 4 0 2017-07-03 10:55:36.977
!MESSAGE SVN: 'SVN Decorator' operation finished with error: Selected SVN connector library is not available or cannot be loaded.
If you selected native JavaHL connector, please check if binaries are available or install and select pure Java Subversion connector from the plug-in connectors update site.
If connectors already installed then you can change the selected one at: Window->Preferences->Team->SVN->SVN Connector.
!STACK 0
org.Eclipse.team.svn.core.operation.UnreportableException: Selected SVN connector library is not available or cannot be loaded.
If you selected native JavaHL connector, please check if binaries are available or install and select pure Java Subversion connector from the plug-in connectors update site.
If connectors already installed then you can change the selected one at: Window->Preferences->Team->SVN->SVN Connector.

Siehe auch den Fehlerbericht in Eclipse bugzilla https://bugs.Eclipse.org/bugs/show_bug.cgi?id=518033

15
lazlev

Sie können die subversiven SVN-Connectors manuell installieren, indem Sie die Aktualisierungssite http://community.polarion.com/projects/subversive/download/Eclipse/6.0/update-site/ hinzufügen : https://polarion.plm.automation.siemens.com/products/svn/subversive/download ) und das Installieren der erforderlichen Pakete, z für native 1.9.x in Eclipse x86:

  • Subversive SVN-Anschlüsse
  • Native JavaHL 1.9-Implementierung
  • JavaHL 1.9.3 Win32-Binärdateien
29
lazlev

Ja, ich hatte das gleiche Problem ... Meine Umgebung ist Eclipse jee oxygen1.

Ich habe zuerst das Subversive installiert ... und wenn das Eclipse-Popup-Dialogfeld "Installationsconnectors" angezeigt wird und ich den Connector auswähle, installiert Eclipse den Connector nicht.

In der Voreinstellung -> SVN-Seite ist das Kombinationsfeld des Verbinders leer.

Ich löste mich wie unten.

  1. installieren Sie neue Software von http://community.polarion.com/projects/subversive/download/Eclipse/6.0/update-site/

  2. wählen Sie sowohl subversive SVN-Connectors als auch die SVNKit-Implementierung aus .. Das Wichtigste ist nicht nur die Auswahl subversiver SVN-Connectors, sondern auch die SVNKit-Implementierung.

  3. installieren und neu starten.

[bearbeitet in 2018-06-29]

Was das Eclipse-Photon angeht, scheint das Problem des SVN-Anschlusses gelöst zu sein.

  1. Installieren Sie einfach das svn plugin (subversiv) über den Eclipse-Marktplatz. (Der Eclipse-Marktplatz befindet sich in "Hilfe - Eclipse Marketplace").

  2. svn-Connector in der Voreinstellung festlegen (Fenster - Einstellungen - Team - SVN - SVN-Connector - Registerkarte)

10
rock-like

Ich hatte das gleiche Problem. 

Wie Lazlev antwortete, habe ich versucht, die Subversive SVN Connectors manuell zu installieren, indem ich die Aktualisierungssite http://community.polarion.com/projects/subversive/download/Eclipse/6.0/update-site/ in "Install neue Software "Fenster. 

Als ich Subversive SVN Connectors und SVNKit-Pakete auswählte, erhielt ich die folgende Fehlermeldung, als MscG erwähnt wurde: 

In der Phase org.Eclipse.equinox.internal.p2.engine.phases.CheckTrust ist ein Fehler aufgetreten. Der Sitzungskontext lautete: (Profil = DefaultProfile, Phase = org.Eclipse.equinox.internal.p2.engine.phases.phases.CheckTru‌ st, Operand =, Aktion =). Fehler beim Lesen von signiertem Inhalt. Ausnahme beim Öffnen der Zip-Datei:\plugins\org.polarion.Eclipse.team.svn.connector_6.0.‌ 4.I20161211-1700.jar

Die einzige Möglichkeit, dies zu umgehen, ist durch: 

-Installieren Sie zuerst den SVN-Anschluss. Starten Sie Eclipse neu.

- Gehen Sie dann zurück zur Installation neuer Software und installieren Sie SVNKit alleine. Starten Sie Eclipse neu.

4
magauthier

Ich verwende Spring Tool Suite 3.9.0, das auf Eclipse oxygen 4.7.0 basiert und das gleiche Problem hatte. 

Aus dem Hilfe/MarketPlace-Menü habe ich "Subservive - SVN Team Provider 4.0.5" .__ installiert. Dann musste ich den svn-Connector manuell über das Menü "Hilfe/Neue Software installieren" installieren. Ich habe diese URL verwendet: " http://community.polarion.com/projects/subversive/download/Eclipse/6.0/update-site/ " Und wählte das SVNKIT 1.8.14 (probierte das 1.8.15 aber es hat nicht funktioniert ...) 

Als Ergebnis erhielt ich schließlich einen Konnektor im Konnektormenü Preference/Team/SVN/SVN ... 

Mit der vorherigen Version von STS hat es besser funktioniert ...

3
iggy

Das Problem scheint der 64-Bit-Eclipse zu sein, da JavaHAL nur in 32-Bit existiert

1
user8633933

Aktualisieren Sie Eclipse Oxygen 1 auf Eclipse Oxygen 3a . Scheint mit Subversive wie ein Zauber zu arbeiten - SVN Team Provider 4.0.5

0
Amy Doxy

Vielen Dank für den Hinweis . Ich habe genau die gleichen Schritte auf Ubuntu ausgeführt, die die für beide Schritte angegebene URL (svn-Connector und svnkit) verwenden: http://community.polarion.com/projects/subversive/ download/Eclipse/6.0/Update-Site/

Es funktioniert nicht mit der neuesten Version von SVNKit mit svnkit url.

0
akkro