wake-up-neo.com

erlaubnis verweigert Fehler bei der Installation von npm

Habe gerade eine Neuinstallation von meinem Ubuntu gemacht und zwangsläufig Dinge wie nodejs npm installiert. Wenn ich ein Projekt geklont habe und versucht habe, Sudo npm install zu installieren, habe ich diese Fehlermeldung erhalten. Hatte jemand das gleiche Problem?

Verwendung von Knoten: 8.9.3 npm: 5.5.1

fetchPackageMetaData error for [email protected]://github.com/gulpjs/gulp.git#4ed9a4a3275559c73a396eff7e1fde3824951ebb Command failed: /usr/bin/git clone -q git://github.com/gulpjs/gulp.git /home/user_name/.npm/_cacache/tmp/git-clone-0e191fc9

fetchPackageMetaData /home/user_name/.npm/_cacache/tmp/git-clone-0e191fc9/.git: Permission denied

Error: Command failed: /usr/bin/git clone -q git://github.com/gulpjs/gulp.git /home/user_name/.npm/_cacache/tmp/git-clone-0e191fc9

/home/user_name/.npm/_cacache/tmp/git-clone-0e191fc9/.git: Permission denied
6
johnny04501

diese Lösung hat für mich funktioniert

 Sudo sudo npm install
15
Unkas

Nur für den Fall, dass die obige Lösung nicht funktioniert, versuchen Sie Folgendes:

Sudo npm install --unsafe-perm=true

0
Raghav Jajodia

Was hier für mich funktioniert hat: Melden Sie sich als root an und geben Sie Folgendes ein

Sudo su
npm install -g npm 

Nicht sicher, ob es das gleiche Problem ist, das ich hatte, aber einen Versuch wert.

0
Shaun