wake-up-neo.com

Fehlender Simulator in Xcode 8.3.2 nach der Installation von Xcode 9.0 Beta

Ich verwende Xcode 8.3.2 für iOS Application Development . Ich habe gerade Xcode 9.0 Beta installiert und plötzlich habe ich festgestellt, dass Meine alten Simulatoren in meinem Xcode 8.3.2 fehlen. .

Dieses Problem trat nach der Installation von Xcode 9.0 Beta auf.

Siehe Bilder unten.

1. Xcode 8.3.2. 

 enter image description here

2. Xcode 9.0 Beta. 

 enter image description here

Ich gehe durch die untenstehenden Links, aber keiner von ihnen ist hilfreich.

  1. Xcode-Simulatoren fehlen nach der Installation von Beta?
  2. Es gibt keinen Simulator in meinem xcode 5, nachdem ich xcode 6 beta installiert habe

Also bitte hilf mir dabei.

21
DJ1

Sie können Xcode> Developer Tool öffnen> Simulator auswählen und nach dem Laden des Simulator-Simulators neu starten. Anschließend erhalten Sie die gesamte Liste zurück.

 Open Simulator Manually

Hinweis: Sie können mit beiden Simulatoren nicht gleichzeitig auf beiden Xcodes arbeiten. Sie müssen einen Xcode mit seinem Simulator schließen, dann können Sie an einem anderen arbeiten.

 Restart Xcode after loading of simulator

Starten Sie Xcode neu, nachdem der Simulator geladen wurde. Sie erhalten eine vollständige Liste von Simulatoren.

65
Ashish Kakkad

Überprüfen Sie Ihr Bereitstellungsziel in den Bereitstellungsinformationen. 

Dies wurde möglicherweise geändert, wenn Sie die neueste Version von Xcode verwenden, bei der Ihr Implementierungsziel automatisch in eine höhere Version des Betriebssystems geändert wird. 

Wechseln Sie einfach zu einer älteren Version des Betriebssystems, in der alle erforderlichen Simulatoren angezeigt werden.  enter image description here

3
iPhoneDeveloper

Die gleichzeitige Ausführung mehrerer Versionen von Xcode wird nur unterstützt, wenn alle Versionen Xcode 9+ sind.

Sie können ältere Versionen installiert haben aber jeweils nur eine Version.

Wenn Sie versuchen, mehrere Xcode-Versionen auszuführen, die dies nicht unterstützen, verliert die aktuell ausgeführte Version den Zugriff auf die Simulatordienste, bis sie neu gestartet wird (an diesem Punkt verliert die andere Version den Zugriff auf ihre Simulatoren).

Beachten Sie, dass Console.app CoreSimulator.framework aus der von xcode-select ausgewählten Version von Xcode verwendet. Wenn Sie Console starten und xcode-select auf eine andere Version von Xcode verweist, verliert der laufende Xcode den Zugriff auf seine Sims.

Für Xcode 10.3 können Sie die Simulatoren zurückholen, indem Sie den folgenden Befehl im Terminal ausführen

Sudo killall -9 com.Apple.CoreSimulator.CoreSimulatorService
3
Chanaka Caldera

Ich hatte das gleiche Problem, Lösung ist: MacBook Neustart :)

2
Robert

Starten Sie nicht mehrere xCode gleichzeitig 

Ich habe diese Fehlermeldung erhalten, weil ich zwei verschiedene xCode-Versionen ausführte

1
tamtoum1987

Führen Sie die folgenden Schritte aus, um dieses Problem zu beheben.

Schritt 1: Beenden Sie den Xcode 9 und seinen Simulator.

Schritt 2: Öffnen Sie Xcode 8 und gehen Sie zu Xcode-Menü -> Entwicklerwerkzeug öffnen -> Simulator.

Schritt 3: Beenden Sie den Xcode 8 und öffnen Sie ihn erneut.

0

nachdem Sie alle von den Benutzern vorgeschlagenen Fehlerbehebungsmaßnahmen ausgeführt haben, falls dies nicht für Sie zutrifft, gehen Sie auf Präferenzen und tippen Sie auf die Registerkarte "Position" und überprüfen Sie, ob die Version des Befehlszeilentools mit Ihrer Xcode-Version identisch ist. Ist Ihre Version des Xcode-Befehlszeilentools auf 9 oder 9+ gesetzt? Setze es wieder auf 8. Hoffe, das wird für dich funktionieren. Danach den Xcode beenden und wieder öffnen

0
Shauket Sheikh