wake-up-neo.com

Firebase-Pod-Installation - Pod 'Firebase/Database' - Erforderliches Mindestimplementierungsziel erforderlich

Ich versuche Firebase/Database wie Firebase zu installieren doc https://firebase.google.com/docs/ios/setup#available_pods , aber als ich es versuchte, habe ich ein Problem.

[!] Unable to satisfy the following requirements:
  • Firebase/Database erforderlich für Podfile

    Spezifikationen, die die Firebase/Database-Abhängigkeit erfüllen, wurden gefunden, erforderten jedoch ein höheres Mindestimplementierungsziel.

Benötigte ein höheres Mindestimplementierungsziel. Wie kann ich das tun?

Vielen Dank

Bildschirmfoto

22
Giovanni Côco

So habe ich es behoben.

Schritt 1 

Installieren Sie Regular Firebase - pod 'Firebase', '>= 2.5.1'

Schritt 2

Update - pod update

* An diesem Punkt dauert die Aktualisierung einige Minuten. Sie sollten so etwas sehen.

Update all pods
Updating local specs repositories
Analyzing dependencies
Downloading dependencies
Installing Firebase 3.2.0 (was 3.2.0)
Using FirebaseAnalytics (3.2.0)
Installing FirebaseAuth (3.0.2)
Using FirebaseDatabase (3.0.1)
Using FirebaseInstanceID (1.0.6)
Using GoogleInterchangeUtilities (1.2.1)
Installing GoogleNetworkingUtilities (1.2.1)
Using GoogleSymbolUtilities (1.1.1)
Using GoogleUtilities (1.3.1)
Generating Pods project
Integrating client project
Sending stats
Pod installation complete! There are 4 dependencies from the Podfile and 10
total pods installed.

Schritt 3

Jetzt sollten Sie Firebase 3 haben. Sie können also Frameworks wie solche in Ihre Pod-Datei einfügen und dann pod update

# Uncomment this line to define a global platform for your project
 platform :ios, '8.0'
# Uncomment this line if you're using Swift
 use_frameworks!

target 'xMarket' do

end

target 'xMarketTests' do

end

target 'xMarketUITests' do

end

pod 'Firebase', '>= 2.5.1'
pod ‘Firebase/Core’
pod ‘Firebase/Database’
pod ‘Firebase/Auth’

Viel Glück!

25
brkr

Ändern Sie in Ihrer Podfile die Zeile pod 'Firebase' in pod Firebase/Core und führen Sie pod update im Projektordner aus. 

Mit der neuen Firebase ist keine erste Zeile erforderlich.

Aus dem Migrationshandbuch:

 migration

Referenz: Firebase.google Migrationshandbuch

4
Idan

sie können versuchen, Podfile.lock zu löschen.

0
Qadir Hussain

In meinem Fall hatte ich einen ähnlichen Fehler, der von Jenkins lief. Als ich den beleidigenden Arbeitsbereich gelöscht und erneut gelesen habe, war alles in Ordnung. 

0
AnneTheAgile

oder Sie können das Podfile aktualisieren

plattform: IOS, '9.0'

"Pod Update" ausführen

das wo

0
Sanjeev

Ich hatte das gleiche Problem. Mein Fehler unten

[!] Unable to satisfy the following requirements:

- `Firebase/AdMob` required by `Podfile`

Specs satisfying the `Firebase/AdMob` dependency were found, but they required a higher minimum deployment target.

 enter image description here Targets->general->deployment target Changed to 8.0 enter image description here

Mein Projekt-Deployment-Ziel beginnt bei iOS 6. Da es in einer älteren Xcode-Version entwickelt wurde. Für die neue Aktualisierung in xcode 8 habe ich den deployment target from ios 8 gemacht.

Nach der Reparatur funktioniert es

Installing Firebase (4.0.2) Installing FirebaseAnalytics (4.0.1) Installing FirebaseCore (4.0.2) Installing FirebaseInstanceID (2.0.0) Installing Google-Mobile-Ads-SDK (7.20.0) Installing GoogleToolboxForMac (2.1.1)

Die neueste Firebase wird von iOS 8 unterstützt.

0
Sheereen S

Folge diesen Schritten:

  1. pod repo master entfernen
  2. pod-Setup
  3. pod installieren 
0
Rincha