wake-up-neo.com

Xcode 9 iOS Simulator wird nach der Installation von Xcode 10 beta schwarzer Bildschirm

Ich weiß, dass so viele Leute diese Frage früher gestellt haben. Aber ich denke, meine Situation ist anders. In meinem Fall war Xcode 9.2 bereits installiert und ich habe macOS von 10.13.2 auf 10.13.5 aktualisiert. Dann habe ich Xcode 10 Beta installiert. Wenn ich nun ein Projekt auf Xcode 9.2 ausführte und versuche, den Simulator zu verwenden, wird es schwarz, obwohl ich die Xcode-Protokolle sehen kann. Dinge, die ich bisher ausprobiert habe,

  1. Deinstallierte Xcode 10 Beta
  2. Xcode 9.2 deinstallieren und erneut installieren
  3. Deinstallieren Sie Xcode 9.2 und installieren Sie Xcode 9.4
  4. Inhalt und Einstellungen zurücksetzen aus dem Simulatormenü
  5. Starten Sie das Gerät über das Simulatormenü neu
  6. Simulator für die Größenänderung.
  7. Folge this post und bereinigte DerivedData, CoreSimulator, iOSDeviceSupport
  8. Fügen Sie erneut Simulatoren aus dem Abschnitt Geräte & Simulatoren hinzu

Was soll ich jetzt tun?

14
Poles

Versuchen Sie, defaults write com.Apple.CoreSimulator.IndigoFramebufferServices FramebufferRendererHint 3 in Terminal ( source ) auszuführen. Beachten Sie, dass Simulator dazu gezwungen wird, OpenGL anstelle von Metal zu verwenden. Sie sollten es also erneut mit 0 ausführen, sobald dies behoben ist.

21
Ted

Eine weitere Option, die für mich aufgetreten ist. Ich habe UIWindow untergeordnet und .init(frame: .zero) aufgerufen. Das Ändern zu .init(frame: UIScreen.main.bounds) hat es behoben.

0
Daniel

versuchen Sie es mit einer Problemumgehung, löschen Sie den Ordner Library/Developer und starten Sie ihn erneut

0
Jack Wilson