wake-up-neo.com

Xcode: Geräteunterstützungsdateien konnten nicht gefunden werden

Während ich versuche, meine Anwendung vom neu aktualisierten Xcode 8 auf meinem iPhone 4 auszuführen, auf dem iOS 7.1.2 ausgeführt wird 

Es wirft unter fehler,

 iOS 7.1.2

Und das ist meine Xcode Version,

 Xcode 8

Hat sich jemand schon früher mit diesem Problem konfrontiert? Warten auf Ihre Vorschläge!

87
Praveenkumar

Ich hatte ein ähnliches Problem, da der App Store-Version die Unterstützung für iOS 10.1 in Xcode 8 fehlte und noch kein Update durchgeführt wurde. Dies führte zu dem Problem "Xcode: Geräteunterstützungsdateien konnten nicht gefunden werden". Sie können das neueste Update https://developer.Apple.com/download/ herunterladen. Es ist aktueller und unterstützt iOS 10.1 (14B72c).

60
Manny

Eigentlich gibt es einen Weg. Sie müssen lediglich den DeviceSupport-Ordner für iOS 7.1 von dem älteren Xcode in den neuen kopieren. Es liegt in:

/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/7.1

Wenn Sie die 7.1-Dateien nicht mehr haben, können Sie eine frühere Version von XCode unter https://developer.Apple.com/download/more/ - herunterladen, extrahieren und diese Dateien anschließend in den folgenden Pfad kopieren

/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/

Kredit

52
Durai Amuthan.H

Sie benötigen Geräteunterstützung von der vorherigen Version von Xcode (7.3.1).

Ich würde empfehlen, dieses Tool zu verwenden: https://github.com/KrauseFx/xcode-install

Wenn Sie Xcode 7 installieren, sollten Sie Unterstützungsdateien mit Xcode 8 verknüpfen:

Sudo ln -s /Applications/Xcode-7.3.1.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/7.* \
/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/
24
Max Potapov

Dieser Fehler wird angezeigt, wenn der XCode alt ist und das verwandte Gerät, das Sie verwenden, auf die neueste Version aktualisiert wird. Installieren Sie zunächst die neueste Xcode-Version.

Wir können dieses Problem lösen, indem Sie die folgenden Schritte ausführen: -

  1. Öffnen Sie den Finder und wählen Sie Anwendungen
  2. Klicken Sie mit der rechten Maustaste auf Xcode 8 und wählen Sie "Paketinhalt anzeigen", "Inhalt", "Entwickler", "Plattformen", "iPhoneOS.Platform", "Geräteunterstützung".
  3. Kopieren Sie den 10.0-Ordner (oder höher für spätere Version).
  4. Wählen Sie erneut im Finder Anwendungen aus .__ Klicken Sie mit der rechten Maustaste auf Xcode 7.3 und wählen Sie "Paketinhalt anzeigen", "Inhalt", "Entwickler", "Plattformen", "iPhoneOS.Platform", "Geräteunterstützung" Fügen Sie die 10.0 ein Mappe

Wenn alles richtig funktioniert hat, hat Ihr XCode ein neues Entwicklerdatenträger-Image. Schließen Sie jetzt den Finder und beenden Sie Ihren XCode. Öffnen Sie Ihren Xcode und der Fehler ist weg. Jetzt können Sie Ihr aktuelles Gerät an alte Xcode-Versionen anschließen.

Vielen Dank

15
Sakshi Singla

Dasselbe Problem mit iOS 10.3 und Xcode 8.2.1. Ich werde die neue Xcode-Beta nicht herunterladen, um das Problem zu beheben. Komm schon, Apple! 

Für alle, die dies lesen, müssen Sie unter https://developer.Apple.com/download/ - die neueste Version herunterladen, die möglicherweise sogar die Beta-Version ist, wenn die stabile Version nicht funktioniert. 

In der Zukunft würde ich wissen, wenn Sie iOS auf Ihren Geräten aktualisieren, können Sie die Xcode/iOS-Version brechen. Aktualisieren Sie daher weise, wenn Sie weiter testen möchten, ohne durch die von Apple erstellten Reifen zu springen. 

8

Wenn Sie XCode 8.1 und iOS 10.2 verwenden, aktualisieren Sie XCode manuell auf 8.2.1. Aus irgendeinem Grund hat App Store dieses Update nicht angeboten.

7
poima

Hier erfahren Sie, wie Support-Fehler von Xcode richtig behandelt werden. Alles, was Sie tun müssen, ist, dem Ordner Xcode's DeviceSupport Unterstützung hinzuzufügen.

Öffnen Sie diesen Link, extrahieren Sie die Zip und kopieren Sie den Ordner. https://github.com/mspvirajpatel/Xcode_Developer_Disk_Images/releases/tag/12.3.1

HINWEIS: Eine neue Version von iOS 13.0 Beta wurde kürzlich veröffentlicht. Wenn Ihr Xcode die benötigten iOS 13.0-Unterstützungsdateien ausgibt, klicken Sie auf den folgenden Link:

https://github.com/amritsubedi/iOS-Developer-Disk-Image/blob/master/13.0.Zip

Dann gehe zu Applications -> Xcode. Klicken Sie mit der rechten Maustaste und öffnen Sie Paketinhalt anzeigen. Fügen Sie dann in Contents -> Developer -> Platforms -> iPhoneOS.platform -> DeviceSupport ein und starten Sie Xcode neu.

Hinweis: Wenn Sie ein Problem mit einer anderen Version von iOS haben, laden Sie das richtige iOS Developer Disk Image herunter und fügen Sie es in den oben genannten Ordner ein.

Das wird funktionieren. Press this to visually see the path.

6
Amrit Subedi
  1. Laden Sie & mount http://adcdownload.Apple.com/Developer_Tools/Xcode_7.3.1/Xcode_7.3.1.dmg .__ herunter. Ich wurde zuerst gewundert, ob er direkt durch hdiutil attach eingehängt werden konnte, und sieht so aus, als könnte er es aber nicht für alle Konten.

  2. Öffnen Sie den Inhalt und kopieren Sie Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/7.1 in den gleichen Pfad in das Xcode-Anwendungsverzeichnis.

  3. Starten Sie Xcode neu
3
Sergei

In der Regel müssen Sie den neuen XCode herunterladen oder aktualisieren. Falls Sie jedoch eine SDK-Datei als Link verwenden möchten, ist die Version 12.2 verfügbar.

Link: https://drive.google.com/open?id=192yLt_VI4dKwrSLN9fzOwKblOKt5Dzkb

Öffnen Sie Xcode als Inhalt und fügen Sie eine neue Versionsdatei ein . PATH: Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/

(Hoffnung hilft iOS-Beta-Entwicklern)

1
Mushrankhan

Gleiches Problem, gehen Sie in den App Store und aktualisieren Sie Xcode

1
Alessio Koci

Ich habe Xcode 10.1 und kann meine Anwendung auf meinem Gerät mit 12.2 iOS-Version nicht ausführen.

Die einfachste Lösung für mich war:

  1. Gehen Sie mit Finder am Xcode-Standort
  2. Rechtsklick -> Paketinhalt anzeigen
  3. Inhalt -> Entwickler -> Plattformen -> iPhoneOS.Plattform -> DeviceSupport
  4. Hier finden Sie eine Liste der unterstützten Versionen. Wählen Sie die neueste und kopieren Sie (In meinem Fall war 12.1 (16B91))
  5. Fügen Sie in den gleichen Ordner (DeviceSupport) ein und rufen Sie ihn mit der von Ihnen benötigten Version auf. (In meinem Fall war es 12.2 (16E227))
  6. Schließen Sie Xcode, wenn Sie es geöffnet haben
  7. Schließen Sie das Gerät erneut an, falls es angeschlossen war
  8. Öffne Xcode und baue

Wenn dieser Trick nicht funktioniert, müssen Sie die Versionen von der neuen Xcode-Version beziehen.

Aber Sie können versuchen, viel Zeit zu sparen. Viel Glück!

1
Gaby Fitcal

Falls Sie "Geräteunterstützungsdateien nicht finden konnten" erhalten, nachdem die iOS-Version Ihres Geräts aktualisiert wurde und Ihr Xcode noch eine alte Version ist, müssen Sie das alte SDK unter neuem Namen einfach neu starten und Xcode neu starten. Öffnen Sie Ihr Terminal und gehen Sie folgendermaßen vor:

$ cd /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/
$ cp -rpv  10.3.1\ \(14E8301\)/ 11.2.1

Starten Sie Xcode neu und es wird höchstwahrscheinlich funktionieren.

0