wake-up-neo.com

Android Studio Gradle-Projektsynchronisierung fehlgeschlagen

Ich erhalte die Fehlermeldung: "." Die Synchronisierung der Gradle-Projekte ist fehlgeschlagen.

Und Fehlerprotokoll:

Error:Unable to start the daemon process. 
This problem might be caused by incorrect configuration of the daemon. 
For example, an unrecognized jvm option is used. 
Please refer to the user guide chapter on the daemon at http://gradle.org/docs/1.10/userguide/gradle_daemon.html 
Please read below process output to find out more:
    ----------------------- 
Error occurred during initialization of VM Could not reserve enough space for object heap Error: Could not create the Java Virtual Machine. 
Error: A fatal exception has occurred. Program will exit.

Ich habe versucht, den .gradle-Ordner zu löschen, als ich hier las. Dies funktionierte gestern, aber heute, als ich Android Studio startete, wurde der Fehler erneut angezeigt und das Löschen des .gradle-Ordners hilft nicht. 

Ich weiß wirklich nicht was ich tun soll. 

Hat jemand irgendwelche Vorschläge? 

21
Sandak

Nur eine blinde Vermutung: Versuchen Sie, Ihrer gradle.properties -Datei im Projekt so etwas hinzuzufügen:

org.gradle.jvmargs=-Xmx512m -XX:MaxPermSize=512m
73
Prizoff

Dasselbe Problem lösen in Android Studio von 

Datei -> Einstellungen -> Compiler (Gradle-basierte Android-Projekte)

Change the "**VM options**" to 
-Xmx512m -XX:MaxPermSize=512m

Es hat für mich funktioniert.

13
Jagadish

Ich hatte das gleiche Problem und habe fast 4 Tage gesucht, kann das Problem jedoch nicht lösen.

Aber endlich kann ich das Problem lösen, und bitte folgen Sie den Schritten.

Schritt 1: Überprüfen Sie Ihre Java-Version. 

Schritt 2: Wenn es 1.7 ist, laden Sie die neue Version, dh das JDK 1.8, herunter

Schritt 3: Installieren Sie JDK 1.8

Schritt 4: Ändern Sie die Java-Version von Android Studio auf 1.8 und die Problem gelöst...

Es hat für mich funktioniert.

4
Prashant Maheta

Die einzige Möglichkeit, das Problem zu beheben, ist, wenn es passiert

./gradlew clean 

und

./gradlew --refresh-dependencies

und starten Sie Android Studio neu.

Wenn das nicht klappt, greife ich normalerweise zurück, um das Projekt neu zu importieren.

4
Andrew G

Ich habe die gleiche Fehlermeldung in Version 2.2.3 erhalten. Also habe ich die neueste Android Studio-Version 2.3.3 heruntergeladen. Selbst in der neuesten Version erhielt ich die gleiche Fehlermeldung. Unten ist meine Lösung: -

  1. Laden Sie die neueste Version von Android Studio von der offiziellen Website herunter.

  2. In Datei> Projektstruktur> SDK-Speicherort , JDK-Speicherort sollte sich auf ein 64-Bit-JDK ex beziehen. C:\Programme\Java\jdk1.8.0_131 , auch danach wurde der Fehler nicht vollständig behoben.

  3. Ich habe die Projektstruktur überprüft. In der Datei> Projektstruktur> Projekt war die Android Plugin-Version war noch 2.2.3 , ich änderte es in 2.3.3 und Der Build ist erfolgreich und alles funktioniert reibungslos .

1
Harsh Saini

das Ändern der Compile-Einstellung zu diesem Zweck funktionierte für mich 

enter image description here

1
Syed Raza Mehdi

Keines davon funktionierte für mich, daher löste ich schließlich mein Problem:

  • Entfernen Sie in der Datei top-level build build.gradle 'classpath' com.Android.tools.build:gradle:einige Versionsnummer '
  • synchronisieren Sie Ihr Projekt und vergewissern Sie sich, dass der Speicherort Ihrer Abstufung auf das richtige Verzeichnis zeigt
0
sav621

Prüfen Sie, ob der Gradle-Pfad in File -> Settings -> Build, Execution -> Gradle korrekt ist. Ich hatte dort einen falschen Pfad zur lokalen Verteilung.

0
seb

Dieser hat für mich gearbeitet.

  1. Schließen Sie das Android Studio 
  2. .gradle Ordner aus c:\users\{username}\.gradle löschen
  3. Öffnen Sie das Android Studio 
  4. Projekt reinigen
  5. Projekt neu erstellen
  6. Projekt mit Abstufungsdateien synchronisieren. Siehe Screenshot

    Prost!

0