wake-up-neo.com

Fehler beim Installieren von Maven Integration für Eclipse

Ich versuche, die Maven-Integration für Eclipse (Galileo) über Install New Software menu nad mit dem Sonatyp-Link zu installieren 

http://m2Eclipse.sonatype.org/sites/m2e

Und folgenden Fehler bekommen: 

Die Installation kann nicht abgeschlossen werden, da ein oder mehrere erforderliche Elemente nicht gefunden werden konnten.
Software wird installiert: Maven-Integration für Eclipse (Erforderlich) 0.12.0.20101115-1102 (org.maven.ide.Eclipse.feature.feature.group 0.12.0.20101115-1102)
Fehlende Anforderung: Maven-Integration für Eclipse (erforderlich) 0.12.0.20101115-1102 
(org.maven.ide.Eclipse.feature.feature.group 0.12.0.20101115-1102) erfordert 'org.Eclipse.emf.ecore.edit 0.0.0', konnte aber nicht gefunden werden

Es wurde versucht, nach dem fehlenden Bundle zu suchen. Aber kein Erfolg. :(

Irgendeine Hilfe?

21
Pale Blue Dot

Aktivieren Sie in Ihrem Installationsmanager "Kontakt mit allen Aktualisierungsseiten ..." und versuchen Sie es erneut. Da EMF von einer anderen Update-Site als M2Eclipse stammt, kann M2Eclipse nicht installiert werden, ohne alle Update-Sites auf erforderliche Komponenten überprüfen zu können.


AKTUALISIEREN!

M2e wird seit Eclipse 3.7 (Indigo) jetzt bei Eclipse.org gehostet. Um es zu installieren, müssen Sie nur die Standard-Eclipse-Aktualisierungssite verwenden:

51

Verwenden Sie Eclipse CDT? Wenn ja, müssen Sie sicherstellen, dass auch die Java-Entwicklungstools installiert sind. Wenn Sie Helios verwenden, verwenden Sie http://download.Eclipse.org/releases/helios/ - als Aktualisierungssite und installieren Sie die JDT-Tools aus der Liste der Funktionen unter "Programmiersprachen". Ich hatte das gleiche Problem und das hat es für mich gelöst.

7
deuberger

M2e wird seit Eclipse 3.7 (Indigo) jetzt bei Eclipse.org gehostet. Um es zu installieren, müssen Sie nur die Standard-Eclipse-Aktualisierungssite verwenden:

http://download.Eclipse.org/releases/kepler
http://download.Eclipse.org/releases/juno
http://download.Eclipse.org/releases/Indigo
etc.

Wenn Sie sich für Eclipse Indigo interessieren, beachten Sie bitte die gelb hinterlegte Antwort und den Screenshot unter dem Link unten

Eclipse Indigo marketplace Maven Integration Installationsfehler

5
Kishor

Ich habe das gleiche Problem (übrigens, "Kontakt mit allen Update-Sites" ist Standard). Ich habe diesen Fehlerbericht in Eclipse bugzilla gefunden, was auf ein Problem im Plugin selbst hinweist. 

https://bugs.Eclipse.org/bugs/show_bug.cgi?id=330896

Ein Workaround für mich ist, auf ältere Versionen von m2Eclipse/m2Eclipse Extras/subversive Integration zurückzugreifen. Ich habe folgende URLs verwendet:

3
jan groth

die Mehrheit von Eclipse unterstützt nicht Maven 3.5 oder 1.8. Um maven zu installieren, müssen Sie zu halp gehen - neue Software installieren Name: M2Eclipse Speicherort: http://download.Eclipse.org/technology/m2e/releases/1.4

für helios: http://download.Eclipse.org/technology/m2e/releases/1.3

Eine andere Möglichkeit, das Maven-Plug-In für Eclipse zu installieren:

  • Öffne Eclipse
  • Gehen Sie zu Hilfe -> Eclipse Marketplace
  • Suche bei Maven
  • Klicken Sie im Abschnitt "Maven Integration for Eclipse" auf die Schaltfläche "Installieren"
  • Folgen Sie den Anweisungen Schritt für Schritt
  • Nach erfolgreicher Installation führen Sie folgende Schritte in Eclipse durch:
    • Gehen Sie zu Fenster -> Einstellungen
    • Beachten Sie, Maven wird auf der linken Seite eingetragen
    • Klicken Sie auf ein vorhandenes Projekt
    • Wählen Sie Konfigurieren -> In Maven-Projekt konvertieren
0
Prabagar g

Stellen Sie sicher, dass Sie während der Installation alle Update-Sites markieren, um die Anforderungssoftware zu finden, bevor Sie mit der nächsten Installation von Maven Integration für Eclipse & m2e-slf4j über die Protokollierungsprotokollierung (optional) klicken.

ich war mit demselben Problem konfrontiert, im Moment hat es das Problem gelöst. Hoffe, das wird hilfreich sein.

0

Um das neue m2e (1.4) auf helios zu installieren, musste ich alle Maven-Elemente in Eclipse deinstallieren und dann konnte ich m2e von http://download.Eclipse.org/technology/m2e/releases "installieren. .

Schritte zum Deinstallieren vorhandener Maven-Elemente (aus org.maven.ide. *):

  1. Klicken Sie in der Hilfe in Eclipse auf
  2. Neue Software installieren ...
  3. Klicken Sie auf Was ist bereits installiert
  4. Wählen Sie alle Elemente aus org.maven.ide. * Aus (auch wenn es erforderlich ist)
  5. deinstalliere sie alle
0
Reda