wake-up-neo.com

Angular 5 ng-bootstrap Typ 'ElementRef' ist kein generischer Fehler

Ich verwende in diesen Versionen 5 und ng-bootstrap:

  "private": true,
  "dependencies": {
    "@angular/animations": "^5.2.0",
    "@angular/common": "^5.2.0",
    "@angular/compiler": "^5.2.0",
    "@angular/core": "^5.2.0",
    "@angular/forms": "^5.2.0",
    "@angular/http": "^5.2.0",
    "@angular/platform-browser": "^5.2.0",
    "@angular/platform-browser-dynamic": "^5.2.0",
    "@angular/router": "^5.2.0",
    "@ng-bootstrap/ng-bootstrap": "^2.1.0",
    "angular-in-memory-web-api": "^0.5.4",
    "angular2-moment": "^1.9.0",
    "bootstrap": "^4.1.1",
    "core-js": "^2.4.1",
    "date-util": "^1.2.1",
    "material-icons": "^0.2.1",
    "ngx-bootstrap": "^3.0.0",
    "normalize.css": "^8.0.0",
    "rxjs": "^5.5.6",
    "zone.js": "^0.8.19"
  },

wenn ich ng serv bekomme hat diese Fehlermeldung:

**

Fehler beim Kompilieren.

node_modules/@ng-bootstrap/ng-bootstrap/buttons/radio.d.ts (58,96): Fehler TS2315: Typ 'ElementRef' ist nicht generisch . node_modules/@ng-bootstrap/ng-bootstrap/datepicker/datepicker-input.d.ts (121,67): Fehler TS2315: Typ 'ElementRef' ist nicht generisch . node_modules/@ng-bootstrap/ng-bootstrap/datepicker/datepicker.d.ts (115,208): Fehler TS2315: Typ 'ElementRef' ist nicht generisch . node_modules/@ng-bootstrap/ng-bootstrap/dropdown/dropdown.d.ts (12,45): Fehler TS2315: Typ 'ElementRef' ist nicht generisch . node_modules/@ng-bootstrap/ng-bootstrap/dropdown/dropdown.d.ts (29,45): Fehler TS2315: Typ 'ElementRef' ist nicht generisch . node_modules/@ng-bootstrap/ng-bootstrap/dropdown/dropdown.d.ts (37,44): Fehler TS2315: Typ 'ElementRef' ist nicht generisch . node_modules/@ng-bootstrap/ng-bootstrap/modal/modal-window.d.ts (13,40): Fehler TS2315: Typ 'ElementRef' ist nicht generisch.

16
GustavoFraga

Ich hatte das gleiche Problem. Also habe ich den ng-bootstrap deinstalliert.

Dann installiere ich es direkt mit 2.0.0 Version.

npm install --save @ng-bootstrap/[email protected]

21
Azac

Sie müssen Angular 6.0.0 oder höher mit ng-bootstrap> = 2.0.0 verwenden. npm/gararn install sollte Sie während der Installation gewarnt haben.

Die Wiederherstellung auf ng-bootstrap 2.0.0 ist nicht eine Lösung, da Sie einfach mit dieser Version einer Bibliothek hängen bleiben und keine Updates/Fixes erhalten. 

Um dieses Problem richtig zu lösen, müssen Sie entweder:

  • upgrade von Angular auf Version 6.0.0 oder höher (empfohlen)
  • lates ng-bootstrap verwenden, das noch mit Angular 5.x (1.1.2) kompatibel ist 
12

Ändern Sie Ihre ng-bootstrap-Version in "2.0.0".

"@ng-bootstrap/ng-bootstrap": "2.0.0"

und dann npm install & versuche die Anwendung.

Ich stand vor demselben Problem und die oben genannte Methode hat für mich funktioniert.

9

Ich stehe plötzlich vor demselben Problem.

In meinem Fall habe ich ng-boostrasp 2.0.0 verwendet, aber ich habe die Abhängigkeiten folgendermaßen angegeben:

"@ng-bootstrap/ng-bootstrap": "^2.0.0"

Was zu einem bestimmten Zeitpunkt (basierend auf Protokollen früherer erfolgreicher Builds: irgendwo seit dem 1. Juni) begann, Version 2.1.0 aufzunehmen.

Also habe ich meine package.json geändert, um genau 2.0.0 auszuwählen:

"@ng-bootstrap/ng-bootstrap": "2.0.0"

Dies hat das Problem von mir behoben.

7
EnjiLenin

Nach der Installation des neuesten ng- bootstrap wurde ein Fehler angezeigt.

Schließlich tun Sie dies

npm install --save @ng-bootstrap/[email protected]

hat geholfen.

0
Athi