wake-up-neo.com

babel-loader jsx SyntaxError: Unerwartetes Token

Ich bin ein Anfänger in React + Webpack.

Ich habe einen seltsamen Fehler in meiner Hello World-Web-App gefunden.

Ich verwende Babel-Loader in Webpack, um JSX in JS zu konvertieren, aber es scheint, als ob Babel die JSX-Syntax nicht verstehen kann.

Hier sind meine Abhängigkeiten:

"devDependencies": {
  "babel-core": "^6.0.14",
  "babel-loader": "^6.0.0",
  "webpack": "^1.12.2",
  "webpack-dev-server": "^1.12.1"
},
"dependencies": {
  "react": "^0.14.1"
}

Hier ist mein webpack.config.js

var path = require('path');
module.exports = {
  entry: ['webpack/hot/dev-server',path.resolve(__dirname, 'app/main.js')],
  output: {
    path: path.resolve(__dirname, 'build'),
    filename: 'bundle.js'
  },
  module: {
      loaders: [
          { test: /\.js$/, exclude: /node_modules/, loader: "babel-loader"}
      ]
  }
};

Hier ist mein app/main.js

var React = require("react");
React.render(<h1>hello world</h1>,document.getElementById("app"));

Und das ist die Fehlermeldung

ERROR in ./app/main.js
Module build failed: SyntaxError: ~/**/app/main.js: Unexpected token (2:13)
  1 | var React = require("react");
> 2 | React.render(<h1>hello world</h1>,document.getElementById("app"));
    |              ^
at Parser.pp.raise (~/**/node_modules/babylon/lib/parser/location.js:24:13)

Danke für euch.

297
Keyu Lin

Add "Babel-Preset-Reagieren"

npm install babel-preset-react

und füge die Option "presets" zu babel-loader in deiner webpack.config.js hinzu

(oder Sie können es zu Ihrem .babelrc oder package.js hinzufügen: http://babeljs.io/docs/usage/babelrc/ )

Hier ist ein Beispiel für webpack.config.js:

{ 
    test: /\.jsx?$/,         // Match both .js and .jsx files
    exclude: /node_modules/, 
    loader: "babel", 
    query:
      {
        presets:['react']
      }
}

Kürzlich wurde Babel 6 veröffentlicht und es gab eine große Änderung: https://babeljs.io/blog/2015/10/29/6.0.

Wenn Sie React 0.14 verwenden, sollten Sie ReactDOM.render() (von require('react-dom')) anstelle von React.render() verwenden: https://facebook.github.io/react/blog/# Changelog

UPDATE 2018

Rule.query wurde bereits zugunsten von Rule.options abgelehnt. Verwendung in Webpack 4 ist wie folgt:

npm install babel-loader babel-preset-react

Dann in Ihrer Webpack-Konfiguration (als Eintrag im Array module.rules im Objekt module.exports)

{
    test: /\.jsx?$/,
    exclude: /node_modules/,
    use: [
      {
        loader: 'babel-loader',
        options: {
          presets: ['react']
        }
      }
    ],
  }
436
Yoon

Ich bin auf ein ähnliches Problem gestoßen, als ich von Babel 5 nach Babel 6 gewechselt bin.

Ich habe gerade babel ausgeführt, um den src to lib Ordner babel src --out-dir lib zu kompilieren.

Ich werde mein Setup für Babel 6 teilen:

Stellen Sie sicher, dass Sie die folgende Version 6 devDependencies installiert haben

"babel-core": "^6.7.6",
"babel-loader": "^6.2.4",
"babel-preset-es2015": "^6.6.0",
"babel-preset-react": "^6.5.0",
"babel-preset-stage-0": "^6.5.0"

Fügen Sie dem Projekt Ihre .babelrc -Datei hinzu:

{
  "presets": ["es2015", "stage-0", "react"]
}
99
svnm

Da die Antwort oben immer noch einige Leute im Dunkeln lässt, könnte eine vollständige webpack.config.js wie folgt aussehen:

var path = require('path');
var config = {
    entry: path.resolve(__dirname, 'app/main.js'),
    output: {
        path: path.resolve(__dirname, 'build'),
        filename: 'bundle.js'
    },
    module: {
        loaders: [{
            test: /\.jsx?$/,
            loader: 'babel',
            query:
            {
                presets:['es2015', 'react']
            }
        }]
    },

};

module.exports = config;
38
Everett

Für mich bestand die Lösung darin, die Datei .babelrc mit folgendem Inhalt zu erstellen:

{
  "presets": ["react", "es2015", "stage-1"]
}
26
albanx

Der folgende Weg hat mir geholfen (beinhaltet React-Hot, Babel Loader und ES2015, React Presets):

loaders: [
      {
        test: /\.jsx?$/,
        exclude: /node_modules/,
        loaders: ['react-hot', 'babel?presets[]=es2015&presets[]=react']
      }
]
22

Das funktioniert perfekt für mich

{
    test: /\.(js|jsx)$/,
    loader: 'babel-loader',
    exclude: /node_modules/,
    query: {
        presets: ['es2015','react']
    }
},
1
jose920405

Ein wirklich gutes Boilerplate von Henrik Joreteg (ampersandjs) finden Sie hier: https://github.com/HenrikJoreteg/hjs-webpack

Dann in deinem webpack.config.js

var getConfig = require('hjs-webpack')

module.exports = getConfig({
  in: 'src/index.js',
  out: 'public',
  clearBeforeBuild: true,
  https: process.argv.indexOf('--https') !== -1
})
0
Maxime Brehin

Für diejenigen, die immer noch vor einem Problem stehen, das Hinzufügen von jsx zum Testen, wurde das Problem für mich behoben

test: /\.jsx?$/,
0
Aftab Naveed