wake-up-neo.com

FEHLER in bundle.js von UglifyJs Name erwartet

Ich versuche, UglifyJS zu verwenden, um meine bundle.js -Datei zu minimieren/komprimieren. Wenn ich webpack -p ausführe, erhalte ich Folgendes:

ERROR in bundle.js from UglifyJs Name expected [bundle.js:105519,6]

Zeile 105519 lautet wie folgt:

const {M, l, pattern} = __webpack_require__(862).

Ich benutze React w/ES6. Irgendwelche Gedanken darüber, was los ist?

18
Colby Cox

Jede Version von Webpack verfügt über eine integrierte Version von UglifyJS (0.4.6), die ES6 nicht unterstützt. Diese Version unterstützt nur die ES5-Syntax.

Es gibt zwei mögliche Lösungen:

  • Transpiler als Ziel festlegen es5
  • Verwenden Sie nicht die integrierte Version von uglifyjs-webpack-plugin und installieren Sie die neueste Version mit npm install -D uglifyjs-webpack-plugin. Fügen Sie es Ihrer plugins-Eigenschaft in Ihrer Konfiguration hinzu:

    const UglifyJSPlugin = require('uglifyjs-webpack-plugin')
    
    module.exports = {
      plugins: [
        new UglifyJSPlugin()
      ]
    }
    
21

Dieser Fehler tritt auf, wenn uglifyjs-webpack-plugin nicht in der Lage ist, Uglify bestimmte Abhängigkeiten aufzuheben

So finden Sie eine Bibliothek, die einen solchen Fehler erzeugt?

Ich benutzte zu reagieren, also löschte ich alle Formulare in meiner App und behielt nur ein Formular bei und importierte alle Abhängigkeiten darin. Remove/add diese Abhängigkeiten eins nach dem anderen Und den Befehl ausführen

webpack -p

SO In meinem Fall handelte es sich um browser-history Erstellen eines solchen Fehlers. Jetzt können Sie dieses Problem dem Autor dieser Bibliothek melden, indem Sie replizierendes Beispiel

working Package.json & .babelrc

0
vijay

Definitiv ein Problem mit der Version von uglifyjs und dem Javascript-Ziel, zu dem Sie kompilieren möchten. Es könnten 2 Dinge sein, Ihr Webpack-Setup und Ihr Babylon-Setup, was dies verursacht.

Wenn Sie die neueste Version von webpack v3.5.5 verwenden, wird das uglifyjs-webpack-plugin ^ 0.4.6 mitgeliefert, das kein Ziel von es6 oder höher unterstützt.

In Bezug auf das aktuelle Webpack docs über UglifyjsWebpackPlugin wird auf die Verwendung der neuesten Betaversion von uglify-js-webpack-plugin v1.0.0-beta.2 verwiesen. Aber ist nicht so klar, wie man diese Version installiert.

Um es mit dem Webpack zu verwenden, machen Sie es

yarn add [email protected] --dev

Da Sie nicht erwähnen, was Ihr Babel-Setup ist. Möglicherweise möchten oder verwenden Sie babel-preset-env als Voreinstellung. Es gibt eine Option für uglifyjs .

Seien Sie großartig, um ein Repo oder einen Gist zu sehen.

0
andykenward