wake-up-neo.com

problem mit dem gulp-Task mit nodejs v10.3.0: src\node_contextify.cc: 629: Assertion args [1] -> IsString () 'ist fehlgeschlagen

Ich habe kürzlich meine nodejs-Version auf 10.30.0 aktualisiert. Alles funktioniert gut. Aber meine Schluckaufgabe funktionierte nicht, was auf älteren Versionen (9.X) einwandfrei funktionierte. Das ist was ich bekomme.

 gulp[11376]: src\node_contextify.cc:629: Assertion `args[1]->IsString()' failed.
 1: node::DecodeWrite
 2: node::DecodeWrite
 3: uv_loop_fork
 4: v8::internal::interpreter::BytecodeDecoder::Decode
 5: v8::internal::RegExpImpl::Exec
 6: v8::internal::RegExpImpl::Exec
 7: v8::internal::RegExpImpl::Exec
 8: 00000384E1284281

Jemand, bitte hilf mir. 

17
M14

Befehl einfach ausführen 

npm install natives
58
nosensus

Ich habe zwei verschiedene Lösungen in zwei verschiedenen Arbeitsbereichen arbeiten lassen. Beim ersten Update auf Knoten 10.6.0 musste ich diese Methode verwenden:

$rm -rf node_modules
$rm -rf package-lock.json
$npm cache clean
$npm install

Der zweite Arbeitsbereich würde nicht mit dem oben genannten funktionieren, obwohl ich es zuerst ausprobiert habe. Ich musste alle meine Abhängigkeiten im Schluckbetrieb neu installieren und dann den npm-Prüfpatch ausführen. Zum Beispiel:

$npm install --dev gulp gulp-sass gulp-autoprefixer
$npm audit fix

Hoffe das hilft jemandem. 

5
jasonflaherty

knotenversion kompatibles Problem, versuchen Sie es mit der Knotenversion <= 9.11.2.

2
邱凯翔

Ich hatte das gleiche Problem. Das Löschen von node_modules und das erneute Ausführen von npm install zur Neuinstallation der in package.json aufgelisteten Module hat für mich funktioniert.

1
Constantine

Mein System:

  1. Windows 10
  2. Knoten 10.15.3

Schritte:

  1. npm update
  2. npm ich Eingeborene
  3. npm ich
  4. npm audit fix

Die Bestellung ist erforderlich.

Meine Pakete nach dem ich über den Befehl "npm update" aktualisiert habe:

{ "name": "your name", "version": "0.1.0", "private": true, "dependencies": { "autoprefixer": "^7.2.6", "babel-core": "^6.26.3", "babel-loader": "^7.1.5", "babel-plugin-async-to-promises": "^1.0.5", "babel-preset-es2015": "^6.24.1", "bootstrap": "v4.0.0-beta", "chartist-webpack": "^0.9.5-0", "d3": "^4.13.0", "d3.js": "^0.0.2-security", "datalist-polyfill": "^1.23.3", "dimple-js": "^2.1.4", "future-tabs": "^1.3.2", "gridstack": "0.2.6", "gulp": "^3.9.1", "gulp-cache-bust": "^1.4.0", "gulp-clean": "^0.3.2", "gulp-connect": "^5.7.0", "gulp-cssmin": "^0.2.0", "gulp-extname": "^0.2.2", "gulp-postcss": "^7.0.1", "gulp-rename": "^1.4.0", "gulp-sass": "^3.1.0", "gulp-sequence": "^0.4.6", "gulp-sourcemaps": "^2.6.5", "ionicons": "^3.0.0", "jquery": "^3.3.1", "jquery-ui": "^1.12.1", "jquery-ui-touch-punch": "^0.2.3", "lodash": "^4.17.11", "md5": "^2.2.1", "moment": "^2.24.0", "natives": "^1.1.6", "postcss-flexbugs-fixes": "^2.0.0", "promise-polyfill": "6.0.2", "semaphore-async-await": "^1.5.1", "url-search-params-polyfill": "^2.0.3", "Vanilla-modal": "^1.6.5", "webpack": "^3.12.0", "webpack-stream": "^4.0.3", "whatwg-fetch": "^2.0.4" } }

0
riwex

befolgen Sie diese Schritte, um ein Problem zu beheben:

Löschen Sie einfach node_modules Verzeichnis und package-lock.json..__ und führen Sie dann npm install --unsafe-perm=true aus.

0
Amir

Ich hatte auch mit gulp ein ähnliches Problem.

gulp build[30580]: c:\ws\src\node_contextify.cc:635: Assertion `args[1]->IsString()' failed. 1: 00007FF6F86BC6AA v8::internal::GCIdleTimeHandler::GCIdleTimeHandler+4506

npm install natives löste das Problem in windows 64

0
kaleem

npm install natives

Dies funktioniert mit Windows 10 64 Bit

0
Shaji Joseph