wake-up-neo.com

Wie ignoriere ich den inkompatiblen Engine "Node" -Fehler bei der Installation von npm-Abhängigkeiten mit Faden?

Mit diesem package.json:

{
  "name": "yarn-install-fail",
  "version": "1.0.0",
  "description": "",
  "main": "index.js",
  "scripts": {},
  "author": "",
  "license": "ISC",
  "dependencies": {
    "aws-sdk": "2.x.x",
    "s3-streams": "^0.3.0"
  }
}

Ich kann die Abhängigkeiten erfolgreich über npm installieren:

$ npm install

added 27 packages in 1.844s

Doch das Garn versagt:

$ yarn install
yarn install v0.24.5
info No lockfile found.
[1/4] Resolving packages...
[2/4] Fetching packages...
error [email protected]: The engine "node" is incompatible with this module. Expected version "^1.2.0".
error Found incompatible module
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.

Es sieht so aus, als hätte Garn Probleme bei der Installation der Bibliothek [email protected], Aber ich ging davon aus, dass es auf alle Abhängigkeiten zurückgreifen würde, wie dies bei npm der Fall wäre.

34
k0pernikus

Sie können solche Fehler in der Tat mit - ignore-engines ignorieren:

$ yarn install --ignore-engines
yarn install v0.24.5
info No lockfile found.
[1/4] Resolving packages...
[2/4] Fetching packages...
[3/4] Linking dependencies...
[4/4] Building fresh packages...
success Saved lockfile.
Done in 1.41s.

Dies ist auch in der Hilfe des Befehls dokumentiert:

$ yarn help | grep -- --ignore
    --ignore-scripts                  don't run lifecycle scripts
    --ignore-platform                 ignore platform checks
    --ignore-engines                  ignore engines check
    --ignore-optional                 ignore optional dependencies
61
k0pernikus

"Garnkonfigurationssatz Ignore-Engines true" Ist eine einmalige Korrektur für das Problem "Der Motorknoten ist mit diesem Modul nicht kompatibel". Sobald das erledigt ist, kannst du "create-react-app my-app" machen

11
Luke Phillips