wake-up-neo.com

RuntimeException Die Zip PHP Erweiterung ist nicht installiert

Ich bin ein Neuling in Linux, ich habe gerade Composer und Laravel installiert ...

aber wenn ich den laravel new project laufen lasse, erhalte ich den folgenden Fehler:

[RuntimeException]
The Zip PHP extension is not installed. Please install it and try again.

Ich weiß nicht, wie ich diese Erweiterung installieren soll ...

bitte helfen Sie

9
Amjad

Versuchen Sie, in die Befehlszeile Folgendes einzugeben:

Sudo apt-get install php7.0-Zip

Überprüfen Sie von jeder Route mit:

dd(get_loaded_extensions());

Das hat bei mir funktioniert, viel Glück.

14
Devin Norgarb

für php 7.0

Sudo apt-get install php7.0-Zip

für PHP 7.1

Sudo apt-get install php7.1-Zip

und so weiter!

5
Harry

Ich habe das gleiche Problem und habe versucht, die Erweiterung mit dem Befehl Sudo apt install php7.0-Zip zu installieren, habe aber immer noch den gleichen Fehler erhalten. Ich habe es endlich mit Sudo apt install php-Zip gelöst

3
Robert Odoch

Ich habe php7.0-zts verwendet.
Die Lösung bestand darin, alle ZTS -Pakete zu deinstallieren und auf die regulären php7.0 -Pakete zurückzugreifen.

1
Aryeh Beitz