wake-up-neo.com

vcruntime140.dll 14.0 ist nicht kompatibel mit PHP build

Ich habe PHP 7.4.1 NTS vc15 x86 auf einem Windows Server 2016-Computer heruntergeladen. Ich habe auch vc_redist.x86.exe Heruntergeladen und installiert.

Wenn ich versuche, php-cgi über die Eingabeaufforderung auszuführen, wird folgende Fehlermeldung angezeigt:

PHP-Warnung: 'vcruntime140.dll' 14.0 ist nicht kompatibel mit diesem PHP Build, der mit 14.16 in Unknown in Zeile 0 verknüpft ist

Irgendwelche Ideen, wie man das löst? Ich denke, ich könnte eine ältere Version von PHP aus den Archiven) installieren, aber dies behebt das Problem nicht wirklich.

28
Ed Mozley

Ich hatte das gleiche Problem. Nachdem ich die neueste Version von Microsoft Visual C++ heruntergeladen hatte, konnte ich dieses Problem erfolgreich lösen. Sie können es hier herunterladen. https://support.Microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads

0
Nkeng Claud

Die Datei vc_redist.x64.exe wurde von hier heruntergeladen und installiert: https://support.Microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads und It funktioniert gut

0
Salman