wake-up-neo.com

Xampp: Der Webbrowser zeigt die localhost-Seite nicht an

Ich habe xampp unter Windows 7 (64 Bit) installiert. Ich möchte mit PHP, Apache und MySql arbeiten. Der Server Apache und die MySql-Dienste werden ordnungsgemäß in der Xampp-Systemsteuerung ausgeführt Mein Webbrowser zeigt nur die Verbindung. Nichts anderes. Verglichen mit der vorherigen Umgebung läuft es gut mit IIS.

9
AnonymousCoder

Versuchen Sie, eine netstat -a auf Ihrem cmd auszuführen, und prüfen Sie, ob andere Dienste auf Port 80 ausgeführt werden. Sie können auch netstat -b verwenden, um den Namen des Dienstes zu finden. Dies erfordert jedoch, dass cmd als Administrator ausgeführt wird. Der wahrscheinlichste Schuldige ist, dass auf diesem Port andere Dienste ausgeführt werden, bei denen Xampp nicht ordnungsgemäß gestartet werden kann. Haben Sie einen Dienst wie Skype? Wenn dies der Fall ist, können Sie nicht auf eine bestimmte Seite zugreifen. Eine andere Sache, die Sie tun können, ist in httpd.conf zu gehen und das Listening auf einen anderen Port als 80 zu ändern und es auszuprobieren. Vergessen Sie nicht, localhost:your selected port hinzuzufügen, sobald Sie den Port geändert haben, um ihn zu testen.

8
user1092042

Wenn Sie Ihre Portnummer geändert haben, geben Sie localhost: 'port number' ein, um zur xampp-Seite zu gelangen.

beispiel: Wenn Ihre Portnummer 8080 ist, geben Sie localhost:8080 ein.

6
Dhanraj Kotian

Es ist möglich, dass IIS oder ein anderes Programm (wie Skype) Apache nicht startet. Obwohl es "läuft" zeigt, läuft es eigentlich nicht.

Um dies zu lösen, gibt es einen einfachen Trick: Installieren Sie Apache als Dienst und starten Sie Ihren Computer neu. Dies wird meistens funktionieren, da es eine Vielzahl von Programmen gibt, die den Port 80 reservieren.

3
user1226868

wenn es nicht der Port ist, gehen Sie zu htdocs, löschen Sie die Dashboard-Datei und die Indexdatei, und Sie können loslegen! :)

1
smix

Wenn Sie Ihren Apache-Empfangsport von 80 auf 8080 geändert haben, dann. . . schreibe localhost: 8080/deine_URL ... es wird funktionieren :)

1
Ankit

Wenn Sie folgende Fehler haben: [Mi 10. Jun 10: 32: 13.697671 2015] [Kern: Warnung] [PID 1408: TID 248] AH00098: PID-Datei C: /xampp/Apache/logs/httpd.pid überschrieben - Unclean Herunterfahren des vorherigen Apache-Laufs? Fehler beim Laden von /usr/local/lib/php/extensions/no-debug-zts-20060613/usr/local/Zend/lib/ZendExtensionManager.sote enthält KEINE ID die mit dem Servernamen übereinstimmt

die ich aus Apache Error Log-Datei extrahiert werde.

Dann müssen Sie den laufenden Prozess von Apache überprüfen, Sie können auch Befehle ausführen oder die GUI verwenden. Ich erkläre die GUI-Methode, den offenen Task-Manager (mit Strg + Umschalt + Esc) und gehe in die Prozessliste und vergewissere mich, dass alle Prozesse einschließlich anderer angemeldeter Benutzer sichtbar sind. Suchen Sie nach dem Apache-Prozess und beenden Sie ihn. Sie sind damit fertig, es mit XAmpp oder Wamp Control Panel auszuführen. 

0
user3819583