wake-up-neo.com

für matplotlib 1.3.1 ist numpy> = 1.5 erforderlich, aber Sie haben numpy 1.8.0rc1, was nicht kompatibel ist

Ich führe folgende Befehle in Mac (High Sierra) aus, um mit pyAudioAnalysis zu beginnen.

pip install numpy matplotlib scipy sklearn hmmlearn simplejson eyed3 pydub  

Ich erhalte während des Installationsvorgangs einen Fehler. Schätzen Sie Ihre Eingabe. 

matplotlib 1.3.1 hat Anforderung numpy> = 1.5, aber Sie haben numpy 1.8.0rc1, was nicht kompatibel ist.

Weitere Informationen finden Sie unten. 

Channas-MacBook-Pro:~ channa$ python
Python 2.7.10 (default, Oct  6 2017, 22:29:07) 
[GCC 4.2.1 Compatible Apple LLVM 9.0.0 (clang-900.0.31)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> 
[3]+  Stopped                 python
Channas-MacBook-Pro:~ channa$ pip -V
pip 10.0.0b2 from /Library/Python/2.7/site-packages/pip-10.0.0b2-py2.7.Egg/pip (python 2.7)
Channas-MacBook-Pro:~ channa$ Sudo pip install numpy matplotlib scipy sklearn hmmlearn simplejson eyed3 pydub
The directory '/Users/channa/Library/Caches/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with Sudo, you may want Sudo's -H flag.
The directory '/Users/channa/Library/Caches/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with Sudo, you may want Sudo's -H flag.
Requirement already satisfied: numpy in /System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python (1.8.0rc1)
Requirement already satisfied: matplotlib in /System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python (1.3.1)
Requirement already satisfied: scipy in /System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python (0.13.0b1)
Collecting sklearn
  Downloading sklearn-0.0.tar.gz
Collecting hmmlearn
  Downloading hmmlearn-0.2.0-cp27-cp27m-macosx_10_6_intel.macosx_10_9_intel.macosx_10_9_x86_64.macosx_10_10_intel.macosx_10_10_x86_64.whl (183kB)
    100% |████████████████████████████████| 184kB 189kB/s 
Collecting simplejson
  Downloading simplejson-3.13.2.tar.gz (79kB)
    100% |████████████████████████████████| 81kB 256kB/s 
Collecting eyed3
  Downloading eyeD3-0.8.5-py2.py3-none-any.whl (167kB)
    100% |████████████████████████████████| 174kB 100kB/s 
Collecting pydub
  Downloading pydub-0.21.0-py2.py3-none-any.whl
Requirement already satisfied: python-dateutil in /System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python (from matplotlib) (1.5)
Collecting tornado (from matplotlib)
  Downloading tornado-5.0.1.tar.gz (504kB)
    100% |████████████████████████████████| 512kB 354kB/s 
Requirement already satisfied: pyparsing>=1.5.6 in /System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python (from matplotlib) (2.0.1)
Collecting nose (from matplotlib)
  Downloading nose-1.3.7-py2-none-any.whl (154kB)
    100% |████████████████████████████████| 163kB 213kB/s 
Collecting scikit-learn (from sklearn)
  Downloading scikit_learn-0.19.1-cp27-cp27m-macosx_10_6_intel.macosx_10_9_intel.macosx_10_9_x86_64.macosx_10_10_intel.macosx_10_10_x86_64.whl (8.0MB)
    100% |████████████████████████████████| 8.0MB 259kB/s 
Collecting python-magic (from eyed3)
  Downloading python_magic-0.4.15-py2.py3-none-any.whl
Collecting pathlib (from eyed3)
  Downloading pathlib-1.0.1.tar.gz (49kB)
    100% |████████████████████████████████| 51kB 54kB/s 
Requirement already satisfied: six in /System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python (from eyed3) (1.4.1)
Collecting futures (from tornado->matplotlib)
  Downloading futures-3.2.0-py2-none-any.whl
Collecting singledispatch (from tornado->matplotlib)
  Downloading singledispatch-3.4.0.3-py2.py3-none-any.whl
Collecting backports_abc>=0.4 (from tornado->matplotlib)
  Downloading backports_abc-0.5-py2.py3-none-any.whl
matplotlib 1.3.1 has requirement numpy>=1.5, but you'll have numpy 1.8.0rc1 which is incompatible.
Installing collected packages: scikit-learn, sklearn, hmmlearn, simplejson, python-magic, pathlib, eyed3, pydub, futures, singledispatch, backports-abc, tornado, nose
  Running setup.py install for sklearn ... done
  Running setup.py install for simplejson ... done
  Running setup.py install for pathlib ... done
  Running setup.py install for tornado ... done
Consider using the `--user` option or check the permissions
5
channae

Ich konnte das mit @ Jacobs Lösung mit einigen zusätzlichen Schritten lösen. Ich werde es hier für alle anderen posten.

  1. Als erstes erwähnte Jacob, dass ich das neueste Python 2.7.14+ heruntergeladen und installiert habe. 
  2. Sudo easy_install pip ausgeführt, um pip erneut zu installieren 

  3. Sudo pip install numpy ausgeführt

4
channae

Laden Sie die neueste Version von Python 2.7 ( https://www.python.org/downloads/ ) herunter. Matplotlib install sollte danach einwandfrei funktionieren.

Wenn es sich um einen brandneuen Mac handelt, stellen Sie sicher, dass Sie Befehlszeilentools installiert haben

1
Jacob