wake-up-neo.com

ProjektFEHLER: Unbekannte Module in QT: Charts

Ich erstelle eine QT-App mit QTwidgets, um sie in einem RaspberyPi3 mit einem mit buildroot erstellten Image auf der SD-Karte auszuführen. Ich nehme an, dass Diagramme unterstützt werden, da sie auf QtWidgets basieren und Widgets unterstützt werden.

Mein Problem ist, wenn ich Charts in mein Projekt integriere und das Projekt auf dem Computer ausführe, gibt es kein Problem. Wenn ich jedoch versuche, dies für die Himbeere bereitzustellen, sind die Dateien und Bibliotheken nicht enthalten und Fehler werden angezeigt.

In meiner .pro-Datei habe ich: QT + = Charts

Dies führt jedoch zu folgendem Fehler:

fehler: Unbekannte Module in QT: Charts

Wenn ich dies jedoch entferne, treten einige Fehler auf, die besagen, dass die Bibliotheken nicht gefunden wurden:

QtCharts/QChartGlobal: Keine solche Datei oder kein solches Verzeichnis

Ich denke, dass mein Problem nur nicht die Verzeichnisse der Bibliotheken oder Plugins in der Himbeer-SD-Karte an das Projekt geben. Kann mir jemand helfen? Wenn Sie weitere Informationen benötigen, fragen Sie einfach. Ich werde mich bemühen, diese so schnell wie möglich zu beantworten.

3
André Alves

Sie müssen das qt5charts-Paket aktivieren, das kürzlich zu Buildroot hinzugefügt wurde. Es ist in unserem 2018.02-rc1 Release Candidate von Anfang dieser Woche enthalten:

http://git.buildroot.net/buildroot/tree/package/qt5/qt5charts

1
Peter Korsgaard

Also habe ich dieses Problem mit der Antwort von Peter Korsgaard gelöst. Ich habe meine alte Bluetooth-Version entfernt, die neue Version installiert, die QtCharts unterstützt ( https://buildroot.org/downloads/buildroot-2018.02-rc1.tar.gz ), und jetzt läuft meine Anwendung. Gefundene Probleme: Hatte den Inhalt meiner cmdline.txt und config.txt geändert, weil sie die neue Version beim Booten zum Absturz brachten und "Kernel Panic" gaben. Ich habe nur die von make generierten Standard-Dateien cmdline.txt und config.txt verwendet und jetzt läuft sie.

0
André Alves