wake-up-neo.com

Bei der Installation von json (1.8.1) ist ein Fehler aufgetreten, und Bundler kann nicht fortgesetzt werden - Rails

Bei der Installation von json (1.8.1) ist ein Fehler aufgetreten. Bundler kann nicht fortfahren. Stellen Sie vor dem Bündeln sicher, dass gem install json -v '1.8.1' erfolgreich ist. Xcrun: Fehler: Ungültiger aktiver Entwicklerpfad (/ Library/Developer/CommandLineTools ), fehlt xcrun unter: /Library/Developer/CommandLineTools/usr/bin/xcrun

make fehlgeschlagen, Exitcode 1

Ich weiß, dass dies bereits veröffentlicht wurde, aber ich habe Bundle-Update, Bundle-Installation und das Einfügen der Gem-Datei in meine Gem-Datei und Bundle-Installation ausprobiert, aber die anderen Antworten funktionieren nicht.

ideen?

6
thatsmesofia

Das Ausführen des "Bundle-Updates" hat für mich funktioniert.

21
Waqas

Sie können bundle update && bundle install versuchen.
Mehr dazu hier .

10
sonlexqt

Ein sicherer Ansatz kann sein: 
bundle update json 
bundle install

6
Edgar Aviles

Führen Sie im Terminal Folgendes aus:

xcode-select --install

Quelle

3
phil pirozhkov

Entfernen Sie Ihre alte Gemfile.lock-Datei und führen Sie das Bundle erneut aus. Eine neuere Version von Json sollte installiert werden.

1

Verwenden Sie unter Ruby 2.4.4 die Sicherungsversion 5.0.0.beta.1. 

gem install backup -v5.0.0.beta.1

Dies hat das Problem für mich gelöst

1
kgehlot