wake-up-neo.com

Fehler beim Erstellen der nativen Gem-Erweiterung - Rails installieren

Ich habe Ruby on Rails nach Anweisung von edX online class installiert.

Hier ist eine Liste der Terminalbefehle und gegebenenfalls der entsprechenden Ausgaben:

$ Sudo apt-get install Ruby1.9.1

installation erfolgreich

$ wget http://production.cf.rubygems.org/rubygems/rubygems-1.8.24.tgz
$ tar zxvf Ruby-1.8.24.tgz
$ cd Ruby-1..8.24
$ Sudo Ruby setup.rb
RubyGems 1.8.24 installed

== 1.8.24 / 2012-04-27

* 1 bug fix:

  * Install the .pem files properly. Fixes #320
  * Remove OpenSSL dependency from the http code path


------------------------------------------------------------------------------

RubyGems installed the following executables:
    /usr/bin/gem1.9.1

Bis hierher sah alles gut aus, aber das habe ich versucht zu installieren Rails und ist fehlgeschlagen:

$ Sudo gem install Rails
Fetching: i18n-0.6.1.gem (100%)
Fetching: multi_json-1.3.6.gem (100%)
Fetching: activesupport-3.2.8.gem (100%)
Fetching: builder-3.0.3.gem (100%)
Fetching: activemodel-3.2.8.gem (100%)
Fetching: rack-1.4.1.gem (100%)
Fetching: rack-cache-1.2.gem (100%)
Fetching: rack-test-0.6.1.gem (100%)
Fetching: journey-1.0.4.gem (100%)
Fetching: hike-1.2.1.gem (100%)
Fetching: tilt-1.3.3.gem (100%)
Fetching: sprockets-2.1.3.gem (100%)
Fetching: erubis-2.7.0.gem (100%)
Fetching: actionpack-3.2.8.gem (100%)
Fetching: arel-3.0.2.gem (100%)
Fetching: tzinfo-0.3.33.gem (100%)
Fetching: activerecord-3.2.8.gem (100%)
Fetching: activeresource-3.2.8.gem (100%)
Fetching: mime-types-1.19.gem (100%)
Fetching: polyglot-0.3.3.gem (100%)
Fetching: treetop-1.4.10.gem (100%)
Fetching: mail-2.4.4.gem (100%)
Fetching: actionmailer-3.2.8.gem (100%)
Fetching: rake-0.9.2.2.gem (100%)
Fetching: rack-ssl-1.3.2.gem (100%)
Fetching: thor-0.16.0.gem (100%)
Fetching: json-1.7.5.gem (100%)
Building native extensions.  This could take a while...
ERROR:  Error installing Rails:
    ERROR: Failed to build gem native extension.

        /usr/bin/Ruby1.9.1 extconf.rb
/usr/local/lib/site_Ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- mkmf (LoadError)
    from /usr/local/lib/site_Ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from extconf.rb:1:in `<main>'


Gem files will remain installed in /usr/lib/Ruby/gems/1.9.1/gems/json-1.7.5 for inspection.
Results logged to /usr/lib/Ruby/gems/1.9.1/gems/json-1.7.5/ext/json/ext/generator/gem_make.out
73
pata kusik

mkmf ist Teil des Pakets Ruby1.9.1-dev. Dieses Paket enthält die Header-Dateien, die für Erweiterungsbibliotheken für Ruby 1.9.1. Sie müssen das Paket Ruby1.9.1-dev Folgendermaßen installieren:

Sudo apt-get install Ruby1.9.1-dev

Dann können Sie Rails wie gewohnt installieren.

Im Allgemeinen ist es einfacher, einfach Folgendes zu tun:

Sudo apt-get install Ruby-dev
160
Suhail Patel

Die vorgeschlagene Antwort funktioniert nur für bestimmte Ruby-Versionen. Einige Kommentatoren schlagen vor, Ruby-dev zu verwenden. das hat auch bei mir nicht geklappt.

Sudo apt-get install Ruby-all-dev

arbeitete für mich.

7
user1821237
Sudo apt-get install Ruby-dev

arbeitete für mich

5
Tanzeel