wake-up-neo.com

Gem :: Ext :: BuildError: ERROR: Die native Erweiterung für die Rails-Version 4.2.6 konnte nicht erstellt werden

Ich habe eine neue Rails-App erstellt und versuche, bundle install auszuführen es zeigt diesen Fehler,

Gem::Ext::BuildError: ERROR: Failed to build gem native extension.
current directory: /var/lib/gems/2.3.0/gems/json-1.8.6/ext/json/ext/generator/usr/bin/Ruby2.3 -r ./siteconf20170704-11395-12tpg5u.rb extconf.rb
mkmf.rb can't find header files for Ruby at /usr/lib/Ruby/include/Ruby.h
extconf failed, exit code 1

Gem files will remain installed in /var/lib/gems/2.3.0/gems/json-1.8.6 for inspection.
Results logged to /var/lib/gems/2.3.0/extensions/x86_64-linux/2.3.0/json-1.8.6/gem_make.out

An error occurred while installing json (1.8.6), and Bundler cannot continue.
Make sure that `gem install json -v '1.8.6'` succeeds before bundling

Bitte senden Sie mir einige Vorschläge, Vielen Dank im Voraus.

5

Wenn Sie einen Mac- oder Linux-Computer haben, versuchen Sie den folgenden Befehl:

Sudo apt-get install Ruby-dev

Wenn dies fehlschlägt, was ist Ihre Ausgabe für:

gem install json -v '1.8.6'

(Bitte kopieren Sie die gesamte Ausgabe und fügen Sie sie ein).

Ähnliches Problem

15

Zuerst haben Sie die Ruby - Version und rvm - Liste überprüft. Wenn rvm nicht installiert ist, installieren Sie rvm.

0
ACHYUT KADAM