wake-up-neo.com

docker-ce: Abhängig: libseccomp2 (> = 2.3.0), aber 2.2.3-3ubuntu3 muss installiert werden

ich installiere das Docker auf meinem Ubuntu-Rechner und folge diesem Tutorial https://docs.docker.com/engine/installation/linux/docker-ce/ubuntu/#extra-steps-for-aufs

wenn ich Sudo apt-get installiere, installiert -y docker-ceit Docker nicht auf meinem Computer und gibt folgende Fehlermeldung aus

$ Sudo apt-get install -y docker-ce
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 docker-ce : Depends: libseccomp2 (>= 2.3.0) but 2.2.3-3ubuntu3 is to be installed
E: Unable to correct problems, you have held broken packages.

Wenn ich Sudo apt-get install libseccomp2 starte, wurde es bereits in meinem System installiert und es wird immer noch derselbe Fehler angezeigt, wenn ich versuche, Docker auf meinem Computer zu installieren.

Hier sind die Informationen meines Ubuntu-Betriebssystems

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04.2 LTS"
NAME="Ubuntu"
VERSION="16.04.2 LTS (Xenial Xerus)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 16.04.2 LTS"
VERSION_ID="16.04"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
VERSION_CODENAME=xenial
UBUNTU_CODENAME=xenial
9
Muhammad Ateek

Wie geht es dir?

Ich bin in Linux Mint (Ubuntu Xenial).

Ich hatte den genauen Fehler.

Die Lösung ist von hier:
https://docs.docker.com/install/linux/docker-ce/ubuntu/#install-docker-ce-1

Ich denke, Sie benötigen eine bestimmte Version wie diese (ich wähle die xenial-Version zuletzt):

[email protected]:~$ Sudo -i
[Sudo] password for patrikx3: 
[email protected]:~# apt-cache madison docker-ce
 docker-ce | 17.12.1~ce-0~ubuntu | https://download.docker.com/linux/ubuntu xenial/stable AMD64 Packages
 docker-ce | 17.12.0~ce-0~ubuntu | https://download.docker.com/linux/ubuntu xenial/stable AMD64 Packages
 docker-ce | 17.09.1~ce-0~ubuntu | https://download.docker.com/linux/ubuntu xenial/stable AMD64 Packages
 docker-ce | 17.09.0~ce-0~ubuntu | https://download.docker.com/linux/ubuntu xenial/stable AMD64 Packages
 docker-ce | 17.06.2~ce-0~ubuntu | https://download.docker.com/linux/ubuntu xenial/stable AMD64 Packages
 docker-ce | 17.06.1~ce-0~ubuntu | https://download.docker.com/linux/ubuntu xenial/stable AMD64 Packages
 docker-ce | 17.06.0~ce-0~ubuntu | https://download.docker.com/linux/ubuntu xenial/stable AMD64 Packages
 docker-ce | 17.03.2~ce-0~ubuntu-xenial | https://download.docker.com/linux/ubuntu xenial/stable AMD64 Packages
 docker-ce | 17.03.1~ce-0~ubuntu-xenial | https://download.docker.com/linux/ubuntu xenial/stable AMD64 Packages
 docker-ce | 17.03.0~ce-0~ubuntu-xenial | https://download.docker.com/linux/ubuntu xenial/stable AMD64 Packages
[email protected]:~# apt install docker-ce=17.03.2~ce-0~ubuntu-xenial
Reading package lists... Done
Building dependency tree       
Reading state information... Done
docker-ce is already the newest version (17.03.2~ce-0~ubuntu-xenial).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[email protected]:~# 

Denn die reine ubuntu hat nicht funktioniert.

9
Patrik Laszlo

Ich hatte das gleiche Problem auf Ubuntu 16. Fast alle Lösung versucht. Der folgende Befehl wird für mich ausgeführt.

Sudo apt install docker.io

Ich habe jedoch festgestellt, dass die neueste Version jetzt mit Docker-ce installiert wird. docker.io ist eine ältere Version. Aber um das Problem zu beheben, müssen Sie eine kompatible Version finden. 

Für mich wird der folgende Befehl ausgeführt, indem Sie den Versionsnamen angeben.

apt install docker-ce=17.12.0~ce-0~ubuntu

Der folgende Befehl listet die Liste der verfügbaren Versionen auf, die Sie nacheinander von oben nach unten ausprobieren können.

apt-cache madison docker-ce

Ich hoffe, das wird Ihr Problem beheben.

7
Bhargav Patel

Bei der Installation von Docker-ce Version 18 tritt das gleiche Problem auf. Ich werde aptitude nicht zur Installation der alten Version verwenden, da nvidia-docker nur Docker-Versionen über 18 unterstützt!

Die Lösung ist ganz einfach:

Sudo add-apt-repository ppa:ubuntu-sdk-team/ppa
Sudo apt-get update

Dann können Sie den Befehl Sudo apt-get install docker-ce verwenden, um das Problem der Version libseccomp2-Version zu lösen.

Referenz: https://Gist.github.com/mingrui/187f0e629007443268ce8c1414012ed5

3
ChenYang

Ich bekomme Ubuntu-Server von unseren Ops, habe das gleiche Problem

Wenn der Start zu graben beginnt, erscheinen in der Datei /etc/apt/sources.list defekte URLs zu Paket-Repos

in meinem Fall war es das

deb http://ubuntu-mirror/ubuntu/ xenial universe

nach Änderung in jeder Zeile ubuntu-mirror in de.archive.ubuntu.com erhalten Sie eine gültige /etc/apt/sources.list -Datei mit URLs

deb http://de.archive.ubuntu.com/ubuntu/ xenial universe

dann

Sudo apt update
Sudo apt upgrade
Sudo apt install -y docker-ce

p.s. ops Update alter 10.04 bis 16.04 und Repos nach dem Update brokend

Ich habe dieselben Probleme auf Linux Mint 18.3 Ich wurde manuell installiert von: http://launchpadlibrarian.net/344879847/libseccomp2_2.3.1-2.1ubuntu2~16.04.1_AMD64.deb

ich entferne keine alte Version

nach der Installation dieser libseccomp2-Installation funktionieren Docker-ce wie acharm.

2

Für Ubuntu 16.04.1 oder neuer ist libseccomp2 in Version 2.3 in Xenial-Updates vorhanden. 

Systemeinstellungen -> Software & Updates -> Updates: Empfohlene Updates

Dann:

Sudo apt update
Sudo apt upgrade
1
Radek

Ich hatte ein ähnliches Problem. Ich habe es mit aptitude anstelle von apt überstanden:

$ Sudo aptitude install docker-ce

Überspringen Sie alle Lösungen und akzeptieren Sie diejenige, bei der behauptet wird, in Konflikt stehende Abhängigkeiten aufzulösen:

The following actions will resolve these dependencies:

     Install the following packages:                    
1)     docker-ce [17.04.0~ce-0~debian-stretch (stretch)]



Accept this solution? [Y/n/q/?] y

Lassen Sie aptitude seine Arbeit machen und es sollte dann docker-ce installiert werden.

$ docker --version
Docker version 17.04.0-ce, build 4845c56
1
ritiek