wake-up-neo.com

Wie deaktiviere ich die automatische Installation von Visual Studio 2015 und höher beim Laden der Lösung?

Jedes Mal, wenn ich die Lösung in Visual Studio 2015 oder 2017 RC öffne, wird automatisch die Bower-Installation für eines der Projekte ausgeführt. Die Ausgabe der Laubeninstallation ist in der Ausgabe Bower/NPM in der Ansicht Ausgabe zu sehen:

PATH=X:\iis\wwwroot\LeExampleProjectName\.\node_modules\.bin;%PATH%
"C:\Users\PC118\AppData\Roaming\npm\Bower.cmd" install --force-latest
bower angular#1.3.14            cached git://github.com/angular/bower-angular.git#1.3.14
bower angular#1.3.14          validate 1.3.14 against git://github.com/angular/bower-angular.git#1.3.14
bower bootstrap#3.3.2           cached git://github.com/twbs/bootstrap.git#3.3.2
bower bootstrap#3.3.2         validate 3.3.2 against git://github.com/twbs/bootstrap.git#3.3.2
bower moment#~2.10.3            cached git://github.com/moment/moment.git#2.10.6
bower moment#~2.10.3          validate 2.10.6 against git://github.com/moment/moment.git#~2.10.3
bower angular-sanitize#1.3.14   cached git://github.com/angular/bower-angular-sanitize.git#1.3.14
bower angular-sanitize#1.3.14 validate 1.3.14 against git://github.com/angular/bower-angular-sanitize.git#1.3.14
bower lodash#3.3.1              cached git://github.com/lodash/lodash.git#3.3.1
bower lodash#3.3.1            validate 3.3.1 against git://github.com/lodash/lodash.git#3.3.1
bower angular-ui-select#~0.12.0 cached git://github.com/angular-ui/ui-select.git#0.12.1
bower angular-ui-select#~0.12.0         validate 0.12.1 against git://github.com/angular-ui/ui-select.git#~0.12.0
bower angular-animate#1.3.14              cached git://github.com/angular/bower-angular-animate.git#1.3.14
bower angular-animate#1.3.14            validate 1.3.14 against git://github.com/angular/bower-angular-animate.git#1.3.14
bower angular-strap#2.2.0                 cached git://github.com/mgcrea/angular-strap.git#2.2.0
bower angular-strap#2.2.0               validate 2.2.0 against git://github.com/mgcrea/angular-strap.git#2.2.0
bower selectize#0.8.5                     cached git://github.com/brianreavis/selectize.js.git#0.8.5
bower selectize#0.8.5                   validate 0.8.5 against git://github.com/brianreavis/selectize.js.git#0.8.5
bower microplugin#0.0.x                   cached git://github.com/brianreavis/microplugin.js.git#0.0.3
bower microplugin#0.0.x                 validate 0.0.3 against git://github.com/brianreavis/microplugin.js.git#0.0.x
bower jquery#>=0.6.0                      cached git://github.com/jquery/jquery.git#2.1.4
bower jquery#>=0.6.0                    validate 2.1.4 against git://github.com/jquery/jquery.git#>=0.6.0
bower sifter#0.3.x                        cached git://github.com/brianreavis/sifter.js.git#0.3.4
bower sifter#0.3.x                      validate 0.3.4 against git://github.com/brianreavis/sifter.js.git#0.3.x
bower jquery#>= 1.9.1                     cached git://github.com/jquery/jquery.git#2.1.4
bower jquery#>= 1.9.1                   validate 2.1.4 against git://github.com/jquery/jquery.git#>= 1.9.1
bower lodash#3.3.1                       install lodash#3.3.1
bower moment#~2.10.3                     install moment#2.10.6
bower angular-sanitize#1.3.14            install angular-sanitize#1.3.14
bower angular-ui-select#~0.12.0          install angular-ui-select#0.12.1
bower angular#1.3.14                     install angular#1.3.14
bower selectize#0.8.5                    install selectize#0.8.5
bower angular-animate#1.3.14             install angular-animate#1.3.14
bower microplugin#0.0.x                  install microplugin#0.0.3
bower sifter#0.3.x                       install sifter#0.3.4
bower angular-strap#2.2.0                install angular-strap#2.2.0
bower bootstrap#3.3.2                    install bootstrap#3.3.2
bower jquery#>= 1.9.1                    install jquery#2.1.4
lodash#3.3.1 bower_components\lodash
moment#2.10.6 bower_components\moment
angular-sanitize#1.3.14 bower_components\angular-sanitize
└── angular#1.3.14
angular-ui-select#0.12.1 bower_components\angular-ui-select
└── angular#1.3.14
angular#1.3.14 bower_components\angular
selectize#0.8.5 bower_components\selectize
├── jquery#2.1.4
├── microplugin#0.0.3
└── sifter#0.3.4
angular-animate#1.3.14 bower_components\angular-animate
└── angular#1.3.14
microplugin#0.0.3 bower_components\microplugin
sifter#0.3.4 bower_components\sifter
angular-strap#2.2.0 bower_components\angular-strap
└── angular#1.3.14
bootstrap#3.3.2 bower_components\bootstrap
└── jquery#2.1.4
jquery#2.1.4 bower_components\jquery

Gibt es eine Möglichkeit, diese automatische Laubeninstallation zu deaktivieren? Und andere Möglichkeiten, um es zu konfigurieren?

25

In VS 2017 können Sie gehen:

Tools -> Options -> Projects and Solutions -> Web Package Management -> Package Restore

Stellen Sie auf false die Wiederherstellungen ein, die beim Öffnen oder Speichern eines Projekts nicht ausgeführt werden sollen:

19

Es scheint nicht möglich zu sein, dies für eine bestimmte Lösung oder ein bestimmtes Projekt zu deaktivieren, aber hier ist wie kann man es global deaktivieren :

  • Gehen Sie in VS zu Extras> Optionen> Projekte und Lösungen> Externe Webtools
  • Deaktivieren Sie alle Suchpfade. In meinem Fall gab es vier davon

Beachten Sie, dass das Ausgabefenster beim Laden der Lösung möglicherweise einige Fehler anzeigt. In meinem Fall beklagte es sich, dass gulp nicht gefunden wurde. Dies hat jedoch keine negativen Auswirkungen.

Alle Tools funktionieren erwartungsgemäß, wenn sie von der Befehlszeile aus aufgerufen werden.

17
theDmi

Sie können die Datei bower.json aus Ihrem Visual Studio-Projekt ausschließen, aber im Projektverzeichnis belassen, um bower manuell auszuführen.

1
BenB

In meinem eigenen Fall (VS2015) habe ich in meinem Projektverzeichnis eine falsche package.json - Datei gefunden. 

Wenn Sie die Datei package.json entfernen, konnte Bower nicht versuchen, "npm install" auszuführen, wenn ich das Projekt öffnete.

0
Diff

Posten Sie einfach eine aktuellere Lösung für dieses Problem, falls jemand auf diesen Beitrag stößt ...

Extras -> Optionen -> Projekte und Lösungen -> Webpaketverwaltung -> Paketwiederherstellung

Stellen Sie die entsprechenden Einstellungen auf "Falsch".

0
NightCabbage