wake-up-neo.com

Windows Phone 8.1-Emulator steckt beim Starten des Betriebssystems fest

Ich habe frische W10 und VS 2015 installiert und jetzt, wenn ich versuche, neu erstellte Hallo Welt Art von App auf Emulator auszuführen, wird es nicht geladen, alles, was es sagt, ist:  Emulator text Nach 5-10 Minuten wird das Programm beendet und Visual Studio gibt die Fehler DEP6100 (Fehler beim Bootstrapping - Verbindung zum Gerät herstellen) und DEP6200 (Gerät nicht gefunden) zurück.

Allerdings wird VM selbst gestartet, bootet und funktioniert in Hyper-V

 VM works

Dinge, die ich versucht habe:

  • Ändern/Reparieren des Windows 8.1-Emulators (nichts geändert)
  • Visual Studio ändern/reparieren (nichts geändert)
  • Installieren Sie Visual Studio neu (nichts geändert)
  • Ändern des Switch-Typs in Hyper V von "intern" in "privat" (Wenn das Fenster des Emulators auftauchte, wurde beim Auflösen der Host-IP-Adresse ein Fehler gemeldet, der jedoch beim Hochfahren aufgetreten ist. Dieses Mal wurde der Windows Phone-Betriebssystem-Startbildschirm gestartet und tatsächlich hochgefahren, Visual Studio jedoch irgendwie Ich habe das nicht erkannt und nach ein paar Minuten des Bootens wurde VM gewaltsam heruntergefahren und es wurden die gleichen Fehlercodes zurückgegeben.)
  • Entfernen Sie alle Ethernet-Adapter (einschließlich meines Computers) und überprüfen Sie, ob Änderungen an der Hardware vorgenommen wurden, damit diese erneut erstellt werden. (Sie wurden neu erstellt, haben aber nicht geholfen, es gibt nur noch 3 Adapter (Ethernet, Wifi und vEthernet (Windows Phone-interner Switch)
  • Milliarden Mal neu gestartet, ohne etwas zu verändern (irgendwie hat es nicht funktioniert)
10
Edgar.A

Nach ungefähr 2 Tagen ununterbrochenem Googeln habe ich eine Lösung aus einer anderen Stapelüberlauf-Frage gefunden, bei der jemand ein ähnliches Problem hatte, aber mit dem Android-Emulator Visual Studio (2015) -Emulator für Android funktioniert nicht - XDE.exe - Exit Code 3

Was ich getan habe war:

  1. Löschen Sie alle VMs in Hyper V
  2. Löschen Sie alle Schalter in Hyper V
  3. Führen Sie xdecleanup.exe für jede XDE-Version aus (zu finden unter C:/Programme (x86)/Microsoft XDE/[8.0/8.1/10.0.10240.0] /XdeCleanup.exe)
  4. Führen Sie Change/Repair unter "Windows Phone 8.1 Emulators - ENU" aus.
  5. Starten Sie Visual Studio neu
9
Edgar.A

Ich habe versucht, was du getan hast und es hat nicht funktioniert. Also habe ich folgendes gemacht:

  1. Gehen Sie zu "Systemsteuerung\Netzwerk und Internet\Netzwerkverbindungen"
  2. klicken Sie mit der rechten Maustaste auf "vEthernet (Interner Ethernet-Port Windows Phone Emulator Internal Switch)".
  3. Wählen Sie Eigenschaften aus, aktivieren Sie den Fall "Hyper-V Extensible Virtual Switch" und klicken Sie auf OK.
  4. Klicken Sie erneut mit der rechten Maustaste auf vEthernet und deaktivieren Sie es. Aktivieren Sie es dann erneut.
  5. Führen Sie das VM aus und warten Sie einige Minuten (das erste Mal ist immer länger zum Laden)
11
DomDev

Ich hatte das gleiche Problem mit den Windows 10 Mobile-Emulatoren, die plötzlich nicht mehr funktionierten, nachdem die Hyper V-Funktionen von Windows 10 einmal deaktiviert und wieder aktiviert wurden.

Was es für mich reparierte, war dieses:

  1. Öffnen Sie Systemsteuerung -> Netzwerk und Internet -> Netzwerkverbindungen

Es sollte einen Adapter mit dem Namen vEthernet (interner Ethernet-Anschluss Windows Phone Emulator Internal Switch) geben. (Tatsächlich hatte ich zwei davon, von denen eines ein rotes Kreuz mit der Aufschrift "Netzwerkkabel nicht angeschlossen" und eines mit der Aufschrift "Nicht identifiziertes Netzwerk" aufwies. Letztere habe ich für die folgenden Schritte ausgewählt.).

  1. Klicken Sie mit der rechten Maustaste auf den Adapter und wählen Sie Eigenschaften
  2. Wechsle zum Tab Sharing
  3. Aktivieren Sie die Option first "Anderen Netzwerkbenutzern erlauben, eine Verbindung herzustellen ...". Deaktivieren Sie die zweite Option "Anderen Benutzern erlauben, eine Verbindung herzustellen oder zu deaktivieren ...".
  4. Als Heimnetzwerkverbindung wähle vEthernet (Interner Ethernet-Port Windows Phone Emulator Interner Switch)
  5. Wechseln Sie zurück zum ersten Tab Networking
  6. Deaktivieren Sie das Kontrollkästchen Internet Protocol Version 6
  7. Klicken Sie im folgenden Meldungsdialog aufOKund dann aufOK(etwas zu IP-Adressen)

Visual Studio 2015 war dabei die ganze Zeit geöffnet. Nach diesen Schritten drückte ich F5, wartete einige Zeit (1-2 Minuten), bis das Betriebssystem bootete und die App gestartet wurde.

(Diese Lösung ähnelt der in den MS Foren vorgeschlagenen.)

Hinweis: Die von DomDev bereitgestellte Lösung hat bei mir nicht funktioniert. Den von Edgar habe ich nicht ausprobiert

2

Dies behebt es für Visual Studio unter Windows 10. Erlaube die folgende App durch deine Firewall. Wenn Sie keine Firewall installiert haben, verwenden Sie die integrierte Windows-Version:

"C:\Programme (x86)\Microsoft XDE\10.0.10586.0\XDE.exe"

Beachten Sie, dass sich der tatsächliche Pfad je nach installiertem Emulator ändern kann.

2
Joey Bowles

Ein bisschen spät und dumm, aber mein Problem war, dass nicht genügend Speicherplatz auf meinem Computer vorhanden war!

0
Benjol