wake-up-neo.com

Auf dem Modell wird iOS 10.2 (14C92) ausgeführt, das von dieser Version von Xcode möglicherweise nicht unterstützt wird

Ich stehe vor diesem Fehler, ich bin mit der Forschung darüber fertig.

Ich schließe das Ergebnis, ich brauche eine Datei für die Geräteunterstützung 10.2 (14C92)

Bitte teilen Sie diese Datei.

Gehe zu:

  • Klicken Sie mit der rechten Maustaste auf Xcode 8 oder eine neuere Version Ihres Xcodes und wählen Sie "Paketinhalt anzeigen", "Inhalt", "Entwickler", "Plattformen", "iPhoneOS.Plattform", "Geräteunterstützung".
  • Kopieren Sie den Ordner 10.2 (14C92) (oder höher für eine spätere Version).

Ich brauche diesen Ordner.

Vielen Dank.

58
Piyush Sanepara

Hier habe ich diese Datei für 12.1 oder 12.0 oder 11.3 oder 11.4 in Xcode 8+ oder XCode 9+. Sie können die Datei über diesen Link herunterladen. 10.3: - https://www.dropbox.com/s/i1f7q8w3vgr2ozl/10.3%20%2814E269%29.zip?dl=

11.3: - https://www.dropbox.com/s/wya3eu2j5db7tpt/11.3%20%2815E217%29.zip?dl=

11.4: - https://www.dropbox.com/s/86i9zjunpsy9b0b/11.4%20%2815F79%29.zip?dl=

12.0 & 12.1: - https://github.com/Yatko/iOS-device-support-files

Schritte:-

Laden Sie die obige Zip-Datei herunter und extrahieren Sie sie.

  1. Klicken Sie in MAC OS auf "Finder"
  2. Klicken Sie auf "Gehe zum Ordner"
  3. Fügen Sie diesen Pfad über den Pfad ein (stellen Sie sicher, dass Sie xcode mit dem Namen "Xcode.app" installiert haben)
  4. Fügen Sie das extrahierte Verzeichnis "10.3 (14E269)" an dieser Stelle ein.
  5. ganz Xcode und starte es neu. Sie können Ihre Projekte erfolgreich auf Ihrem realen Gerät ausführen.

Wenn Sie die neueste Version nach 12.1 herunterladen, laden Sie diese Datei hoch und aktualisieren Sie die Antwort.

5
Piyush Sanepara

Wenn jemand ein ähnliches Problem mit Xcode 9.1 hat enter image description here

  1. Verzeichnis öffnen:

    /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport

  2. Erstellen Sie einen neuen Ordner "11.2 (15C107)" (oder "10.3 (14E269)" für ältere Versionen, je nachdem, was genau Sie vermissen)

  3. Einfügen von Dateien aus dem angegebenen Google Drive-Ordner

    11.2 (15C107) (oder 10.3 (14E269) falls Sie ältere Dateien benötigen)

  4. Starten Sie Xcode neu

Für andere iOS-Versionen können Sie die Antwort von @Sour LeangChhean überprüfen

Denken Sie daran, dass Sie eines Tages ohnehin Ihren Xcode aktualisieren müssen :)

14
Yurii Koval

Hier habe ich diese Datei für 10.3 oder 11.3 oder 11.4 in Xcode 8+. Sie können die Datei über diesen Link herunterladen. 10.3: - https://www.dropbox.com/s/i1f7q8w3vgr2ozl/10.3%20%2814E269%29.zip?dl=

11.3: - https://www.dropbox.com/s/wya3eu2j5db7tpt/11.3%20%2815E217%29.zip?dl=

11.4: - https://www.dropbox.com/s/86i9zjunpsy9b0b/11.4%20%2815F79%29.zip?dl=

9 -> 12 Alle Dateien: https://github.com/mendaparadarshit/xcode-9-ios-12-support

Schritte:-

  1. Laden Sie die obige Zip-Datei herunter und extrahieren Sie sie.
  2. Klicken Sie auf "Finder" in MAC OS. Sie können in der oberen Leiste alle Menüs sehen. Klicken Sie auf "Go".
  3. Klicken Sie auf "Zum Ordner" ()
  4. Fügen Sie diesen Pfad über den Pfad ein (stellen Sie sicher, dass Sie xcode mit dem Namen "Xcode.app" installiert haben)
  5. Fügen Sie das extrahierte Verzeichnis "10.3 (14E269)" an dieser Stelle ein.
  6. ganz Xcode und starte es neu. Sie können Ihre Projekte erfolgreich auf Ihrem realen Gerät ausführen.

Vielen Dank,

Darshit

Ich hatte genau das gleiche Problem. Gerade auf xcode Version 8.2.1 (8C1002) aktualisiert und das Problem wurde behoben.

10
Daniel Castro

So bauen Sie ein Gerät mit iOS 10.3 und Xcode 8.2.1 auf:

  1. Nächstes Verzeichnis öffnen: /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport
  2. Neuen Ordner "10.3 (14E277)" erstellen
  3. Dateien kopieren: DeveloperDiskImage.dmg, DeveloperDiskImage.dmg.signature VOM Ordner 10.2 (14C89) ZUM neuen Ordner 10.3 (14E277)
  4. Starten Sie Xcode neu

enter image description here

2

Ich habe das Problem durch ein Update von Xcode gelöst.

Aus irgendeinem Grund wurde das Update jedoch NICHT im App Store im Bereich Updates angezeigt. Ich musste den App Store manuell nach Xcode durchsuchen und GET und dann INSTALLIEREN auswählen. Es wurde eine neuere Version installiert und das Problem wurde behoben.

Nicht sicher, warum Apple tut dies für Entwickler ...

2
lenooh

sie müssen Ihren xCode auf die letzte aktuelle Version aktualisieren. In jeder Version ist die letzte iOS-Version enthalten.

1
user6562549

Ich habe dieses Problem und habe es gelöst, indem ich die neueste Xcode-Version heruntergeladen habe.

1
bigeyesung

Ich habe die entsprechende Zip-Datei von https://github.com/iGhibli/iOS-DeviceSupport/tree/master/DeviceSupport für die Version meines Geräts von iOS heruntergeladen

Entpackt den enthaltenen Ordner nach

/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport

Und schließlich Xcode neu gestartet. Xcode muss nicht selbst aktualisiert werden

0
Jase Whatson